Graphics bug + freeze in Final Fantasy VI SNES Arabic Translation

Started by Xenniex1, May 27, 2022, 04:49:13 AM

Previous topic - Next topic

Xenniex1

I started playing Final Fantasy VI SNES, the Arabic Translation.

After the main intro, the player is forced to battle 2 soldiers. The battle however looks how you see in the picture. I cannot finish the battle. Sometimes it just freezes in that battle as well.
Picture: https://ibb.co/6t5RhvS

As you can see, I cannot see my battle actions and there is a weird graphical error.

I would love to fix the issue. I really want to play this romhack.

Jorpho

imgbb seems to be down at the moment.

So, obvious question: what emulator are you using? Or are you using original hardware? Have you tried a different emulator?

If the patch requires a ROM with a header, then did you make sure your ROM has a header, or vice-versa? (It would be unusual if it made it all the way past the main intro if it was a header issue, but nonetheless.)
This signature is an illusion and is a trap devised by Satan. Go ahead dauntlessly! Make rapid progres!

Xenniex1

I tried 3 different emulators and had the same result each time.
There was a headerless rom required and that is what i used. That should not be the issue.

Green Jerry

I've just patched it to an unheadered 1.0 ROM and had no graphics glitch in the soldier battle.

Have you checked the version of your ROM? Maybe you have version 1.1 (Rev 1). The translation expects version 1.0.
My latest Portuguese translation: Popeye (NES)
New English translation! Gardman (NES)

Linktree

T29

Quote from: Xenniex1 on May 27, 2022, 04:49:13 AM
I started playing Final Fantasy VI SNES, the Arabic Translation.

After the main intro, the player is forced to battle 2 soldiers. The battle however looks how you see in the picture. I cannot finish the battle. Sometimes it just freezes in that battle as well.
Picture: https://ibb.co/6t5RhvS

As you can see, I cannot see my battle actions and there is a weird graphical error.

I would love to fix the issue. I really want to play this romhack.

Judging by the name of the screenshot you post, you are using the v1.1 (Rev 1), and this hack it's for the v1.0. 
You have to get the v1.0 rom (You'll notice that the name hasn't the "Rev 1" when you find the right one)
:thumbsup: :thumbsup: :thumbsup:


Xenniex1

Quote from: T29 on May 29, 2022, 07:12:35 PM
Judging by the name of the screenshot you post, you are using the v1.1 (Rev 1), and this hack it's for the v1.0. 
You have to get the v1.0 rom (You'll notice that the name hasn't the "Rev 1" when you find the right one)
:thumbsup: :thumbsup: :thumbsup:


Thank you so much. It worked when I used v1.0. I really appreciate the help. You guys are awesome!