Hex editors not displaying kana from table file

Started by jomteon, May 20, 2022, 06:35:40 AM

Previous topic - Next topic

jomteon

I've tried about a dozen different hex editors, and a couple different ROM/tables, but keep having the same problem.

I'll use windhex for my examples here, since problem is nearly identical wherever I encounter it.

I go into Windhex and open my ROM for editing. Then I open my table file. All I see is this:



(It should show something along the lines of スタートを押してくたさい on line 1D10 instead)

When I go to examine it in the table editor, I see:



As an interesting counterpoint, when I, for example, open up the NES Mesen emulator and run the memory viewer there, and load in the tbl file, everything works as expected.

I've tried a whole host of things to solve this, but I'm out of ideas. What can I do?

Zynk


jomteon

Quote from: Zynk on May 20, 2022, 09:23:49 AM
Ctrl+D

Ah, should have mentioned that I already tried setting things to "View Text Data as Japanese" (both manually in the menu and with ctrl+D). No luck.

When I do that I get this crazy output:




KingMike

Is your TBL file saved in Shift-JIS format?
(Despite the menu saying "Display Text as Unicode", I think WindHex actually supports just SJIS)
"My watch says 30 chickens" Google, 2018

jomteon

#4
Quote from: KingMike on May 20, 2022, 07:46:46 PM
Is your TBL file saved in Shift-JIS format?
(Despite the menu saying "Display Text as Unicode", I think WindHex actually supports just SJIS)

I don't think so!

After reading your response I did some googling, but I came up empty handed. Can you recommend me a way/piece of software to save a TBL file in Shift-JIS format?


I'm not 100% sure that'll fix the issue though, because another wonky issue, that seems to point to something deeper, is that even when I use the native Table Editor/Maker in WindHex, the kana don't show up right. More specifically, when go to input the data, it will show the kana correctly in the input bar. But when I hit enter, it shows up as gobbledygook.

https://i.imgur.com/7PgaNGX.png

Nvm, I figured it out with Notepad++ (go to Encoding>Character Sets>Japanese>Shift-JIS)

It seems to be working now! Some kinks to be worked out with the table I think, but I feel like I'm on the right path.  Thank you all for your help!