11 March 2016 - Forum Rules

Main Menu

Link's Awakening Revision [Project]

Started by Phantron, September 08, 2021, 05:46:54 PM

Previous topic - Next topic


Hello, I've been working on the game (DX version) with the LALE editor, and I managed to change and improve the game as I had it in mind for the very most part. It has been almost a year ago that I had worked on it now :D

At first, I gonna list my changes:
- a lot of places in the overworld now have earlier accesses and additional shortcuts
- the 4 teleporters have all been placed somewhere else except the first one
- overworld map's tiles graphics are closer to what they represent in the actual game
- almost every dungeon has been overhauled to be more clear and slightly more difficult
- the first Boss has been made slightly easier (pit holes are just closer to the walls) while any Boss from the 3rd on has been made harder (mostly just slightly)
- added graphically sticking out tiles to places you can interact with Marin for photographs when leading her to the walrus, and other cryptic photos
- reduced the amount of seashells to 24 (removed the 3 way too easy ones and added 1 other in the boat riding minigame)
- a good bunch of general small fixes in the world (for example made entering the dog house from behind impossible)
- redesigned a few puzzles and little things all around (for example the 5 chests one in a cave on the mountain is no longer cryptic luck)
- etc etc

Thing is, I have ZERO programming knowledge etc, and there are a bunch of errors and unfinished stuff (just a bit). if someone with knowledge would like to help me out, would be SUPER appreciated :)

here's the list of errors:
- the new overworld teleporters have neither the actual connected rooms for them nor do they teleport at all, you just fall in them and respawn with damage
- I added new stones which's sprites have a bugged graphic when picking them up in the room with the coconut throwing monkey, because in the next room I added a teleporter and it'd allow to use it super early if you just enter said room so I had to block that
- in a few areas in general sprites graphics bug out where I added the shortcuts, and the rooster's graphic does too in a room in which I added another flamethrower where you'd need to use the mirror shield (you can get to the room before you find the shield)
- I've added a shortcut outside along the last caves towards D7 if you have the rooster, and I wanted the player to fall down into the water cave below with the holes but it doesnt work
- a new position added for a spawning chest in D7 doesnt make it appear normally, only after re-entering the room
- due to a new hole falling "puzzle" in D7 I added a new falesafe hole on the highest floor, but it needs the connection to said room below
- a slightly different reposition of a falling-off ledge infront of D7 doesnt update into the game (so you dont fall down to the water cave directly anymore)
- a stair sprite in D8 is shown as a switch block graphic instead, due to there being those too now (in the room right to the fish Sub-Boss)
- both of 2 lock-blocks dissolve after just 1 of them gets opened in the room towards the entrance to the main Sub-Boss of D8
- the newly added seashell in the boat riding minigame didn't update into the game
- the underground sidescrolling section for entering the castle received bugged background graphics after modifying the game
- newly placed heart piece 3 rooms right to the entrance of D8 didn't update into the game (removed the one from ontop D8's outer section)

I just found about a new version of the LALE editor. Will def take a look at it!

Also I heard about ASM, but I have no knowledge how that works at all, and I've already read me in a bit about that, didn't help me much...
However here are documents for the game

you can also add me on Discord at Phantron#3093 to directly chat (I have further ideas in mind I personally cannot implement) and I can distribute my romhack-patch there easier :)


Hey, anyone who is somewhat firm with scripting / programming for this game? :)


Noone? :(
Sad, I wish I could finish this project... this way it's broken.


have you tried asking in the romhacking subreddit? Perhaps there's more movement there. Or you can also try at gbatemp.


You could also try the help wanted section here.