News: 11 March 2016 - Forum Rules

Author Topic: Need help with Faxanadu Restoration.  (Read 1906 times)

someone7

  • Newbie
  • *
  • Posts: 1
    • View Profile
Need help with Faxanadu Restoration.
« on: May 23, 2020, 08:42:40 pm »
I've tried sending the author a private message on this forum, but I'm guessing he probably won't see it any time soon. So I figured, why not come to the forum and ask the people here for help?
Anyway, my basic problem is that I can not get the Faxanadu Restoration hack to work. In the description, it says it requires the Japanese rom which has a crc32 checksum of A80FA181. What is not stated is that this checksum is only produced by a headerless Japanese rom image, which took me hours to figure out (it was just a guess after trying out so many different roms).
So when I first downloaded the patch, and applied it to a normal (with a header) Japanese rom, it seemed to be working. I got to input a name, and the game played normal up to the point where you approach the walls of the city. Then it froze. I figured, maybe it was because I patched the wrong rom? Hours later, after finally figuring out that the crc32 checksum required refers to a headerless rom, I used the tools on this site to remove the header, and applied the patch. But this corrupts the file in such a way that no emulator I've tried will run it, as they no longer recognize it as a proper NES rom at all.
Using another tool on this site to save the normal Japanese rom's header, and then to inject it back into the patched binary, only produces a grey screen. So I'm at a loss at this point. It seems that the normal (with a header) Japanese rom is the way I want to go, but that also fails. What I want to know is, does anyone else have this problem? Can someone try applying this patch to the normal Japanese rom, and see if they are having the same issue? Or is there some special procedure I am supposed to use when applying this patch? Any advice greatly appreciated.

darkmage

  • Jr. Member
  • **
  • Posts: 6
    • View Profile
Re: Need help with Faxanadu Restoration.
« Reply #1 on: June 04, 2021, 12:02:41 pm »
Second this - I cannot get the 1.01 patch to work, and I have a non-header ROM file for Faxanadu (J) that matches the CRC32, but I have the same problem someone7 is: Intro plays, get to the door into the castle, a text box pops up and then the game hangs.

EDIT: Should note that I'm using the (NES) patch file. I'll try the FCEU one just in case.