News: 11 March 2016 - Forum Rules
Current Moderators - DarkSol, KingMike, MathOnNapkins, Azkadellia, Danke

Author Topic: snes neugier 50hz  (Read 806 times)

gorgyrip

  • Jr. Member
  • **
  • Posts: 45
    • View Profile
snes neugier 50hz
« on: January 09, 2021, 03:22:18 pm »
The translation freezes at the main menu in 50hz on real hardware.
https://www.romhacking.net/translations/398/
The same does the japanese rom.
This can be replicated only in zsnes (force as pal in the loading window).
How can this be fixed?

J^P

  • Full Member
  • ***
  • Posts: 136
    • View Profile
Re: snes neugier 50hz
« Reply #1 on: January 09, 2021, 04:48:13 pm »
mod your console for 60hz  :P or buy NTSC snes.

Thorbs

  • Jr. Member
  • **
  • Posts: 9
    • View Profile
Re: snes neugier 50hz
« Reply #2 on: January 10, 2021, 04:02:27 am »
This can be replicated only in zsnes (force as pal in the loading window).
How can this be fixed?

I recommend playing this on a real SNES system in combination with the FXPAK Pro flashcart.
The FXPAK Pro automatically adapts the ROM to the given console you are using, but I think you can also force NTSC/PAL modes with it.

goldenband

  • Sr. Member
  • ****
  • Posts: 340
    • View Profile
Re: snes neugier 50hz
« Reply #3 on: January 10, 2021, 11:24:17 am »
There are a fair number of games targeted for 50Hz that reliably crash when played at 60, so I'm not at all surprised that the opposite is true. In the case of 50 > 60 my understanding is that the lack of VBLANK time at 60Hz (and 525 lines) is often the culprit; no idea what would cause the reverse issue, but I'm sure it's something arcane and hard to debug.  :(

gorgyrip

  • Jr. Member
  • **
  • Posts: 45
    • View Profile
Re: snes neugier 50hz
« Reply #4 on: January 11, 2021, 04:55:29 am »
There are a fair number of games targeted for 50Hz that reliably crash when played at 60, so I'm not at all surprised that the opposite is true. In the case of 50 > 60 my understanding is that the lack of VBLANK time at 60Hz (and 525 lines) is often the culprit; no idea what would cause the reverse issue, but I'm sure it's something arcane and hard to debug.  :(

Can it also be a vblank issue in my case? In 50hz the title screen is blank, music plays, but i can't press any button. If I switch it to 60hz, the menu appears, I can start the game and switch it back to 50hz and it works.