11 March 2016 - Forum Rules

Main Menu

Mato Projects (mostly FF4/6 stuff)

Started by Tomato, April 21, 2020, 05:51:06 PM

Previous topic - Next topic

Kain Stryder

Hey Mato, been a while! Haven't seen you stream in a very long time, glad to see you're doing ok. A friend linked me here, wanted to say hello and give some info on T-Edition.

You may or may not remember me, but a few years back you had helped me with your hacking notes on T-Edition via email on your stream. I'm part of a project for translating T-Edition (currently via lua scripting and ips patches). Our work is *mostly* done, slowly touching up the dialogue and polishing things with a bunch of quality of life additions thanks to the lua. We also translated all the help files Tsushiy made and hacking notes for modders in his html files. Seeing you do a translation is awesome, and allows console to play (ours can be played on console but not with the lua currently, where dialogue is either garbled or in Japanese - the rest of things like items, etc are in English). We've had nothing but headaches getting this game into English, (and the bugs, all the bugs lol) let alone hacking dialogue into the game, so seeing you do it is great!

As far as the translation goes, are you also aware or correcting any bugs/glitches? We've documented a *lot* of the issues with T-Edition and fixed them/reported it to Tsushiy. That said, if you want any help or even to combine your work once done let me know. We can toss you some bug fix ips patches or just inform you of a list of things, either or. My goal from the start was to get this game into English and get fans playing/enjoying the massive amount of work that went into it :)

Speaking of Tsushiy, he went MIA for over 2 years and popped back a month or so ago, apologizing for disappearing. He has little motivation for modding anymore but wanted to at least fix bugs and such if possible. My team and several Japanese posters on his forums submitted bug reports/fixes and he updated the file from 2.9.1 to now 2.9.4 (there's a handful of new features, even a nice new Setzer base sprite he added). If you recall during your older playthrough, that "using an item in battle and you got Ultima" or something, that bug was found/fixed. Currently, there's an even bigger bug with any item ID above 256 we've reported on (and submitted the solution to *finally* be rid of it), but he sadly hasn't posted in over 3 weeks now... if he doesn't pop back, we plan to fix it ourselves (and documented any current/known bugs on our forums and in the download and work arounds for them).

We've also released a MSU-1 for the mod to help fix the music to sound how he intended it on uosnes, due to SNES 9x or other emulators sounding off or beeps/boops (Tsushiy offered me a fix but admitted it still doesn't sound "as good", but was content that it at least fixed it a little, but the MSU-1 completely corrects it).

In any case, let me know, would love to talk more in-depth on the project/mod in general, as it's been our passion for the last few years. Keep up the great work!


Unfortunately I don't know much when it comes to music hacking, so I won't be able to fix that on my own. I believe the current theory is that data stored in HiExROM areas have a slightly different read time, leading to the wonkiness. If that's true, it could be possible to relocate most of the songs to safe areas and move existing data to the HiExROM areas, but that would be like doing brain surgery without any experience.

Right now, I have a note added to the NPC who explains about the Music Player that some songs might sound wonky on modern emulators and hardware. In the readme I'll try to emphasize that it sounds correct in Snes9x v1.51.

Kain Stryder: Yo! I actually saw your posts on Tshushiy's board and know what issues you're talking about. I haven't done any serious long-term playtesting yet so I don't really have much to report in regard to that on my end. If you have bug fixes and stuff, that'd be cool for sure. Actually, now that I think about it, I did fix a bug that doesn't display the esper's name when looking at the spells the esper teaches, but it was minor and probably not even noticeable. I was considering looking into the Joker Doom exploit, I recall it was something viewers kept asking about. I don't know how much Tsushiy did about it himself, though, except that it seems more formations have the no-Joker Dooms bit set.

There's also that bug that's documented with screenshots in the patch's .zip file that deals with using items in a battle when a >256 item is in the bottom row. I assume that's what happened with the weird Ultima thing I had that one time.

I actually started my project in late January so it's coming along pretty quickly. I didn't realize until recently that the Lua workaround translation was so robust though, I had heard it simply did item names, enemy names, basic strings, etc. You got basically everything working already :o When I saw screenshots/videos of it in action a few days ago I was like "oh no, I hope this doesn't turn into a rivalry thing like the old days", haha. It reminded me of the old Dragon Quest I+II translation rivalry that suddenly appeared out of nowhere like 18 years ago.

I did indeed see the new 2.9.4 update. When I saw it, I was like ARGH because I thought it was safe to do a translation finally, after like 2.5 years of no patch updates. A few days ago I wrote some code to see the text differences between versions should any new Japanese patches get released. I actually haven't asked him for permission to do a translation or even told him I'm working on one yet, so I hope he won't mind. It's sad to hear that he's lost motivation, but I super understand the feeling.

Anyway, it's clear you guys have worked hard so I didn't mean to step on your toes. Hopefully I didn't make anyone upset by posting about my project. On my end, I had considered trying to move the bad music data to MSU-1 or some other solution too, but I decided I'm mostly interested in the translation side of things and that more serious hackers would figure out that wacky technical music stuff.

Kain Stryder

Haha, nah no worries on rivalry or stepping on toes. By all means don't stop your project, you're even more than welcome to collaborate it with us (we were working on an actual ips patch translation for the dialogue to bypass lua for console users, and to try and minimize the patching to get our work loaded up, but it was a back burner thing), but if you want to keep it separate that's more than fine, we won't be mad or offended or anything. My goal as I said was just to get this mod into English and get other fans to enjoy it. How we reached that goal, I didn't care, I'm not in this for glory or if others stepped up with something, I'd just be elated. I just simply wanted to inform you to the 2.9.4 update and bugs/glitches for your project, in the event you may not have been aware (and I had also figured you saw he hadn't done anything in 2.5 years and decided it was safe to make a patch finally) and offer the collab chance with you :) When I started this, no one was seriously invested in doing it (or rather, many had tried but gave up/got frustrated, which is extremely understandable when you delve into the code work). I simply just started translating the help me files so people could use them as guides while they played. Shortly afterwards, I met someone who had done a very rough menu hack and from there we teamed up and got the ball rolling to what you see today.

You're more than welcome to pop by our Discord if you use that to talk, though I understand you're busy and have other projects. I can have our lua girl discuss things a bit easier (I'm not the person who handled the lua) like for fixing bugs or adjusting the coding. Your work would also allow our project to simplify itself and even do a lua lite mode with quality of life changes added into it (especially for console users). Our script for example uses the GBA dialogue, then any new dialogue Tsushiy added in was done by myself (we felt re-translating a game with an already solid translation was pointless and we didn't want to offend anyone's memories or come across as "holier-than-thou"). But please, by all means, don't feel pressured if you don't want this or if you'd offend anyone. I think I can say with certainty everyone here would be elated to see you do a translation, myself included. I'm no professional :P

And sure, bug fixes I can toss up. Tsushiy actually fixed/removed that item ID 256 graphic for 2.9.4 from the help me files, but the one I mentioned in my first post persists (we actually originally figured it was a very rarely occurring bug, as I had seen only a few streamers get it). We determined the root cause of it:

When you open a treasure chest containing an item with ID256+, for the game to load the item name, it sets $1444 to 1. This does not get cleared.

When an item is dropped in battle, it checks if $1444 is 1, which gets set during the "formation special drop" routine, and if so, drops an item with ID256+. Unfortunately, during battle, the $1444 is never cleared, so if it was set beforehand, an enemy who drops "item 0xE8" will instead drop "item 0x1E8" which is not a valid item.

Accessing the main menu clears $1444, so opening the menu before a battle will prevent this from occurring. Maybe at the start of a battle it should clear $1444 though?

High chance of this occurring when acquiring the chest with "Experience Egg" and then immediately fighting Ultima Buster without checking the menu first.

Other bugs that were fixed for 2.9.4 were a "level up 2x or more" glitch where stats weren't updating correctly (Ultima Weapon/Atma Weapon) was not getting stronger. He re-added the Experience Egg to the game, but this caused issues and seemed to upset him when he himself discovered a bug (sometimes equipping relics, they are greyed out, but it's a display error only; you can still equip them). He said if he can't solve it, he'll just remove the egg again.

I wasn't aware of the esper thing you fixed, though we had completely redone the menu work so that probably just got overwritten haha.

Mostly, if you update your stuff to 2.9.4 you should be ok, but the stuff I listed above are the glaring issues right now (the item ID256 thing is fixable). Other known issues are:

- Locke's "Sky Pirate" costume is not selectable in EX via the moogle
- Gau's Rage achievement unlocks at 240 rages possibly instead of 255, due to the following (copied from Discord):

The "Tonberries" rage is that last bit, for 0x8000, but it's completely unusable in the game, so it will never appear on your rage menu.
So normally if you have all 255 rages, excluding Tonberries, your rage data will look like
however if you have Tonberries and none of the other last 14 rages, which makes the last two bytes 0x8000 ... well, 0x8000 is equal to or greater than 0x7FFF, so the check passes. Of course, Tonberries + any other of the 14 rages works too since 0x8C2F or whatever is still higher than 0x7FFF
The list of skippable rages, as long as you have Tonberries fought as Gau, is Amduscia, Baalzeph, Chronos, Daedalus, DthMachi, Garm, GlasyaLa, GoldBear, InnoSent, Io, MtlHitmn, Necroman, Pineappl, RedMarsh, Thor
I just checked this in-game by fighting Tonberries while having all of those rages missing, it does indeed set the proper 'rage bit' even if you can never use it

- 200,000 step achievement unlocks randomly (we don't know the cause)
- Unable to enter the esper menu on x character sometimes (does that X sound like when you try to enter Banon's equip menu). We don't know the cause and I've only seen 1 streamer have the issue. Corrected itself upon saving/reloading.
- Entering the Cave to the Ancient Castle coming from the Ancient Castle has the music sound beep/boop, don't know the cause of it. MSU-1 fixes it.

As for MSU-1, I *believe* my friend put the coding into Cyan's Bushido stuff, but I can always ask her (we had a little bit of an issue finding space). For the music, the reason it sounds off is because uosnes has unlimited audio ram compared to other emulators, so Tsushiy was able to use I believe additional sound channels etc (this was explained to me, I'm also not at all familiar with music/SNES music coding, sorry if I botch any of the details). Due to the coding, 9x and others has issues playing this. Tsushiy's solution is: in 9x go to Emulation >>> Hacks >>> OK >>> Check Separate Echo Buffer from RAM, and this'll fix the music beep/boop sounds mostly, but says the music still sounds "slightly off". For the most part, our MSU-1 stuff is complete (though she's working on the inn music jingles and victory fanfares still, but those will be auto added to the file and no additional downloading is needed).

Permission wise, I'm sure Tsushiy would be more than fine with you working on this :P he mentioned you when he returned (that he originally watched your stream of it), and has had no problems with me working on it when I asked him years ago, more so elated his work is seeing interest overseas, as he never dreamed English players would be interested. He said he'd check some of the streams/LP's I linked for him to see what was done and was looking forward to working with us, so I sincerely doubt you'd upset him, haha. His only thing was that if we changed anything to just please rename the mod so people don't associate it with him and annoy him with bug reports etc. All the optional content (lua quality of life, things he wanted to add but couldn't figure how to, etc) or work we've added has stayed optional or you can turn off; we've replaced none of his work. I just hope he doesn't disappear again.

But yeah bug fix wise, everything should be in the 2.9.4 ips file, barring what I wrote above as current known issues (that we're aware of). If you need more info, feel free to let me know!


Quote from: Tomato on March 10, 2021, 07:35:02 PM
Unfortunately I don't know much when it comes to music hacking, so I won't be able to fix that on my own. I believe the current theory is that data stored in HiExROM areas have a slightly different read time, leading to the wonkiness. If that's true, it could be possible to relocate most of the songs to safe areas and move existing data to the HiExROM areas, but that would be like doing brain surgery without any experience.

Right now, I have a note added to the NPC who explains about the Music Player that some songs might sound wonky on modern emulators and hardware. In the readme I'll try to emphasize that it sounds correct in Snes9x v1.51.
/wave, I'm the Lua coder.

The music issues are caused due to the instruments using up too much data (?) so the audio info overflows into the RAM dedicated to the music's echo. There's a "hacks" setting in snes9x(-rr) 1.60 that allows you to separate the echo RAM which lets it play okay.

The MSU patch that was thrown together uses the SRAM for Cyan's Swdtech names (7E1D0A-7E1D0E) because, for the Lua version, I knew that RAM was unused since the Lua completely disregards the text that's there and prints the skill names directly in 8x8 font (because I'm a scrub who couldn't figure out how to get the wide font to not display the tall glyphs in the 18xx range). So that could be an incompatibility if you just read from that RAM... although the screen to let you change the name is gone anyways so there's not much harm in hardcoding the names.

I think what you have in the screenshots is significantly better than what we have anyways. I've been staring at that GBA font too long, ahaha. We never put together a real EX patch, for EX I only threw together a minimum-possible-effort patch in order to make it playable in English, there's still various gibberish in places. The Lua effort only works on a single emulator, if you don't use that one then 95% of the text in the game is just garbage text because there's no script or monster names or anything else in the base IPS patch.

2.9.4 should be fine to install? I used LocksmithArmy's patch conflict checker to compare 2.9.4 to what we had done and there was no issues (though for you, of course you might be using some various offsets that we didn't use, especially when it comes to the ASM).

If you wanna talk patches or bugfixes or whatever, we're in #ff6-t-edition on the NGPlus Discord.


Whoa, thanks for all the info and tips!  :beer:

For the music glitches, I have no doubt that you're correct since your emulator fixes seem to solve the problem. I assumed the HiExROM read time was the issue due to this thread from a while back: The fact that the Ancient Cave music doesn't always glitch adds more mystery to the pile, although I recall that I could get some glitchy songs in the music player to sound correct by playing certain songs immediately beforehand. Crazy stuff there. I'd love if there were a surefire fix for the problem but it's probably going to go beyond the scope of what I can do with my project.

I don't have an easy way to test the $1444 bug but here's a patch that should hopefully fix it. Let me know if it works/doesn't work for you:

For the step counter bug, I haven't looked into any of that at all, but I wonder if there's a missing CLC command before the addition occurs across all the bytes. That could potentially throw things off. I might look into it later but it sounds like it's hard to reproduce, so it might not be solvable.

I'm not sure what could cause the equipment graying out bug, but I was handling that code a few weeks back while working on the main menus so I could take a peek sometime. I haven't come across this problem yet either, but I haven't done much playtesting since 2.9.4 anyway. I can't even remember where the Exp. Egg is supposed to be, I guess it's in Kefka's Tower based on your $1444 bug notes though.

The Tonberry bug is interesting, and I don't have any fix ideas in mind yet but I imagine the easiest solution would be to just have it ignore the Tonberry bit during the check, then unlock when 254 rages have been detected. This would bring it closer to the intended purpose and not surprise anyone out of the blue. The Tonberry rage would still be gettable and usable, just not counted in the total. That, or just subtract 1 from each byte when checking and then check for 0xFE for all the bytes except the Tonberry one which would be 0x7F.

The Sky Pirate thing I don't think I'll be able to fix, as I haven't worked with the game's scripting at all and wouldn't know where to start. I imagine it'd get pretty messy and I'd be liable to cause unseen trouble with any potential clumsy fix. I could just put a note in the Moogles' text about going back to T-Edition to switch to it if the player wants.

Kain Stryder

The music stuff can't be corrected beyond the 9x solution or MSU-1 which we recently released, just because of how it was coded. For the most part, it seems fine with the fix, and MSU-1 just fixes it completely to sound how it should (and opens the ability for any other MSU stuff in the future if we or anyone decides and wants to :D! )

I reported the $1444 thing to Tsushiy to let him patch/fix it, just so we didn't do it then have to undo our work to patch his stuff and anything else (saves us a hassle), but it's going on a month now since his last reply and he didn't acknowledge my last post yet. If you want to test the issue yourself, simply get any of the following items (via a treasure chest or a battle):

Hero's Ring, Guard Bracelet, Dead Spirit, Prayer Beads, Black Belt, Dragon Horn, Celestriad, Master's Scroll, Bacchus's Bracer, Safety Bit, Mime's Dictionary, Bracer, Tetra Elemental, Embroidered Tippet, Soul of Thamasa, Zeidrich, Flame Cape, Wind Corsage, Earth Greaves, Water Cuffs, Maiden's Prayer, Imp's Feelings, Piggy's Badge, Experience Egg

Any of these items will work. The trick is get one of them, then *do not open your menu*, enter a battle and try to win an item, it doesn't matter what. It should come out like this:

You'll get a garbage data item that will most likely corrupt your game or cause issues. The lua warns you to sell it asap if you highlight it in the menu. Auto-sorting it either makes it disappear (still will cause issues) or puts it wherever. How we tested and figured the cause was a streamer got the Experience Egg from a chest, then ran and fought a boss (had Molulu's Charm on to avoid battles), never opened his menu, beat the boss and the 100% drop is the pic you see above. Serity checked the memory and determined the issue and semi solution till it can be patched (opening the menu fixes it).

This is just if you want to further test anything. I went ahead and tested your patch and it worked perfectly! Thank you! We'll add it up and I'll report it to Tsushiy when he hopefully pops back (or feel free to yourself, I'm sure he'd freak hearing from you :P). My test personally was I went and got the Experience Egg from
The Floating Continent in the WoR which is accessed via a new tower NE of dino forest. Treasure Chest at the very end of it. Did a save, took the egg, did a battle vs Ramuh/Ifrit/Shiva clones and won. Got a garbage item. Applied your patch and reloaded, got the egg, did the same fight, got a Fire/Thunder/Ice Rod (very lucky lol), so it's fixed.) The other location for the egg is winning the new fight from Kefka on the FC at the end of the WoB.

From what Serity tells me, the greying out equipment persisted from older versions, but I've never seen it or seen a streamer have the problem. It's just been recently with relics only, to where Tsushiy himself posted the bug report for it. He thinks it might be due to the Experience Egg being put back in, but Serity tells me it's not the case due to the above, and how the cause is unknown. It's just a graphic display though, thankfully.

I did report all this to Tsushiy, but again, no response yet. One other small issue I reported was his new Setzer sprite, he forgot to put in the 2 small graphics for it when riding a Chocobo (the world map ones), so it just displays Setzer's original back sprite for it, not the new one. I can fix this myself, but was waiting for Tsushiy to handle it first. If he doesn't, I'll just correct it, it's not a big deal.

One small note for your translation to check, that we had issues with: Make sure to play test or trigger the ending if you can (where it shows the like "Terra as Terra Branford" etc scenes). Due to our tampering with names, it comes out all odd colored at parts on those screens (red/blue/green). Just graphical errors but otherwise the sprite scenes are fine. Our issue seemed to be that the ending screen would show say "Kakata (just random katakana and not what the player has them named as) as Terra Branford" but the kata was all pushed together. I guess just names in general to check? That was really our only issue outside of the Name Screen that we had to completely rework.


Whoa, I had no idea about that Tower of Power place, seems like it'll be fun to re-explore.

The character names during the ending was pretty simple to fix, the game was just trying to load from further down in the font data than needed for English purposes:

I took a peek at the grayed out equipment bug, but I'm not sure how to fix it myself. But when it happens with one character, it seems you can reproduce it on other characters too by removing whatever equipment is on their left hand.

Kain Stryder

Oh nice, I'm glad it was simple to fix, we haven't gotten around to it yet ourselves.

Yeah there's a LOT of stuff he's added since you streamed, should've seen the chaos from 2.5 to 2.7, haha. He had two soft locks (he changed Thamasa Inn's music so during the house on fire event the game just stopped due to eventing, and going down to the save room on the FC just froze you for some reason). Another was he added a small house north of Narshe on the world map, which produced *actual lag* to the game upon entering and walking around. Clicking spaces around the map gave you random items or battles, such as the Cyan event at the Imperial Camp fights or even corrupted items.

If you stream it again, or even just play through the game casually, you'll really enjoy alot of what he did or added/changed up.

We'll keep looking into the relic greying on our end and keep you posted if we discover anything. The "left hand" part you discovered sounds big, so we'll make a note of that.


Do you know if any enemies drop any of the >256 extended items?

Kain Stryder

Yeah there's a bunch. I don't think our scan/steal/drop data shown below shows any of the 256 drops due to I want to say it's specially coded? I forget the reasoning, Serity mentioned it to me once. If it's something that needs to be known let me know, but yeah our data just doesn't show it in the picture below off the search tool we made. Kefka below for example does drop the Experience Egg 100% if you beat him, I know that for sure.

However, this list was compiled by us from the data, so just ctrl+f any item to find all instances in the game of what chest or enemy has it:


Quote from: Tomato on March 15, 2021, 07:09:16 PM
Do you know if any enemies drop any of the >256 extended items?
Enemies do not drop >256 items. However, "formations" do, which is a new feature that was coded in (the drops, not the formations). 0x4B4A00+(0..0x2D6 [726]) is single-byte item ID (add 0x100 to get proper item ID). Formations can only drop extended items, they can't drop normal items.


Thanks, it looks like I had the >256 item drops working properly for battles already, whew!

I'm about halfway through the Bank 2 script text at the moment but I'm not sure where this sort of text appears in the game:

I'm assuming that some of those blank paintings get filled up if you do certain things, like maybe defeat EX bosses? Or is there some other place that this text shows up?

Kain Stryder

Those are the descriptions of the paintings, yeah. As you clear bosses in EX, then transfer your save data back over to the base game, the paintings appear with descriptions when examined.

Also if you run into song lyrics like this:

  [1015] =[[Run through the cold<NL>          of the night<NL>As passion burns<NL>         in your hearts<EOP><NL>Ready to fight, a knife<NL>     held close by your side<EOP>Like a proud wolf alone<NL>

They're from the Developer's Room at the Maria NPC, if you play certain songs from the music player and then speak to her. From memory she sings a FF3 song, a Xenogears song (shown above, which is NOT an actual song in the player (title is Star of Two Pieces), and one other I'm forgetting. There's also a mass of dialogue for each FF6 song that the Opera House NPCs in the same room comment on if you play a song in the room and speak to them.


I ran into this bug recently, and it's unrelated to any of my work - it happens in Japanese FF6T. The timer during the Night Patrol event acts crazy on the main menu and counts down by 64 (or I assume something is being bit-shifted right a bunch of bits) instead of showing the actual current countdown timer:

I first noticed this issue when using bsnes-plus for my debugging/testing purposes. It doesn't seem to occur with snes9x though. So I tested it on hardware as seen in the video above, and it matches bsnes-plus.

I think this is the only countdown timer that goes above 10 minutes in the game? If so, then it seems like Tsushiy added some code to calculate the tens minute digit, which might be what causes this.

I actually ran into a similar issue when testing the timer during the Ultros-dropping-tons-of-weight on Celes scene, but I thought I had fixed it. Looking back, maybe I had just tested my fix in snes9x.

Have you guys seen this countdown timer problem? Are you able to re-create it at all?

Kain Stryder

I've never seen an issue with the timers before like that. Mostly because we uses 9x or 9x-rr due to the lua, as does everyone I've seen streaming it. I've only had a few people use actual hardware and from memory it never had the issues you're showing. Tsushiy codes for uosnes, so any other emulator will have problems or he can't guarantee it'll work properly. There was recently on his forums a poster showing problems via an emulator I think called SNEShout or something (an emulator discontinued in 2002? somewhere around there). His Umaro had no actions and would freeze the game, and entering Kefka's Tower and doing certain events caused a freeze/empty room to appear. Tsushiy couldn't replicate the errors at all and others chalked it to the emulator. Possibly the same case here. I did as a safety go and check 9x-rr on my end and both our translation and the Japanese patch have no issues.

Excuse the weird names in the Japanese picture, it's a result of our editing:




Do you happen to have a save file that's far into the game? I'm actually using save files from my old 2014 run, so there's a chance that's involved here. It's not likely, given the RAM addresses used but I wanna make sure before I try to fix it or decide to ignore it.

Kain Stryder

I do, I have one that's end game (and saved/ready for EX), I'll PM it to you on here.


Thanks! I tried it out and the problem is still there. I guess it's just something that's broken on actual hardware/more accurate emus. It seems to be connected with how Tsushiy carved out a tiny bit of RAM in that $1440 block, in this case he uses $144d and $144e to handle the enhanced time counter/display routine for the main menus. I can't make sense of why it happens though, so I'll probably just have to leave it as a bug in the readme or something.

Kain Stryder

Huh, interesting. I asked the two guys I know that play on hardware to test it on their end, but haven't heard back yet, but if you figured the issue, I'll also make a note, thanks for finding it!

Edit: One guy just got back to me:


Okay, I found the issue: Tsushiy skips a bunch of NOPs that seem unimportant, but they're actually there so that the game waits until the division registers finish their work. So basically the bugged timer was reading in garbage data from un-finished division math.


The fix is simple enough, just change the instruction at $c33355 to "jmp $335e". A simpler way is to hex edit the byte at $c33356 to 0x5e, or use the cheat code "c333565e".

EDIT: It might also be helpful to let the snes9x dev community know about the division delay issue, since the current snes9x builds don't demonstrate this bug that's present on hardware and bsnes-plus.