News: 11 March 2016 - Forum Rules
Current Moderators - DarkSol, KingMike, MathOnNapkins, Azkadellia, Danke

Author Topic: Zelda 1 Redux / The Legend of Zelda Redux  (Read 205187 times)

kaine23

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #620 on: February 28, 2021, 09:20:53 am »
i'm definitely gonna be playing redux 1-3 in April now!

Chicken Knife

  • Sr. Member
  • ****
  • Posts: 499
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #621 on: March 03, 2021, 02:13:03 am »
Have been truly enjoying this project. It fixes pretty much every genuine issue I had with the original game, while thankfully leaving the combat challenge well enough alone.

Unfortunately, I just hit a major bug at the end of the game:



After obtaining the Red Tunic (but not the Silver Arrow), every time I load the game, graphics go nuts after a few seconds. The screen cycles through various incorrect tiles every second or so. If I go to a different save file, this doesn't happen. (additional info, I currently have max heart containers, no monster bait, the medicine script, full triforce, all other items)

The only other bug was the one mentioned previously where small parts of the graphics on screen, mostly the map, would become corrupted, but entering a dungeon would fix them. That issue was livable.

Other feedback:

The old guys who hold the sword upgrades says: "Become stronger and you shall have this." That statement is fine when you don't have enough hearts, but it sends the wrong message when you do. I suggest changing to: "Gain enough strength and you shall have this."

Also, shield movement. It bothers me a bit that when you walk side to side, the shield moves up and down, but when you walk downward, the small shield wags side to side. I'd personally adjust it to match ALTTP and have it move up and down. But then we have the problem of the large shield which is totally static walking downward but still goes up and down with side to side movement. I did a bit of looking into it, and there would certainly be some complexity involved with making those adjustments.

In any case, bravo to the excellent project. I'll be eagerly awaiting a fix to the junk graphics bug so I can complete the game.  :thumbsup:

ifightdragons

  • Full Member
  • ***
  • Posts: 153
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #622 on: March 03, 2021, 04:28:31 am »
Just finished this myself, and can confirm that there are some map bugs.

The overworld map becomes glitched quite often.

The dungeon map only displays the room you are in, no matter if you've found the map. It works on the pause screen/inventory though.

ShadowOne333

  • Hero Member
  • *****
  • Posts: 1621
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #623 on: March 03, 2021, 10:34:30 am »
To the people having the map bugs.
Are you using the same save for the game since the beta patches?

There was a flag that was being set in an address in RAM that shared data with other stuff in the betas for quite some time, fixed only recently in January/December I believe.

So if you are having corruption map issues, try with a clean save.

Chicken Knife

  • Sr. Member
  • ****
  • Posts: 499
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #624 on: March 03, 2021, 10:51:15 am »
I didn't start the game until the published version was released.

ifightdragons

  • Full Member
  • ***
  • Posts: 153
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #625 on: March 03, 2021, 11:19:24 am »
I didn't start the game until the published version was released.

Same here, had no previous saves.

ShadowOne333

  • Hero Member
  • *****
  • Posts: 1621
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #626 on: March 03, 2021, 01:06:48 pm »
What version of the game are you playing?
I will need as many details, and also a video if possible when the issue first occurred.
The graphics cycling is precisely the bug with the animation I fixed weeks ago, so it could be a carried value or oversight of the previous flag address. The map corruption I'm not sure yet, I have to see it in action to theorize what it can be.

A save and/or save state right before it happens could help too.
« Last Edit: March 03, 2021, 01:35:39 pm by ShadowOne333 »

Chicken Knife

  • Sr. Member
  • ****
  • Posts: 499
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #627 on: March 03, 2021, 03:27:23 pm »
I'm playing 1.0, the published version.


Here's a link to my save, a before state, an after state, and a video.

https://www.dropbox.com/sh/48bm7sdmw7pl8hb/AABpe_5Ue8jnug5PoTsyT7o8a?dl=0

I'm having a hard time remembering if I used the MMC1 or MMC5 patch. If water is animated, that means I used MMC5, correct?
« Last Edit: March 03, 2021, 03:37:03 pm by Chicken Knife »

ifightdragons

  • Full Member
  • ***
  • Posts: 153
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #628 on: March 03, 2021, 03:49:16 pm »
I'm using the latest 1.0 No Intro-version, patched with MMC5.

PowerPanda

  • Full Member
  • ***
  • Posts: 182
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #629 on: March 03, 2021, 04:56:45 pm »
Same. I'm using MMC5, and not a beta version. I have played it on 3 different systems (PC with FCEUM, Homebrew enabled 3DS, and Retroid Pocket 2), and have gotten the tile issue on all of them. I made sure that my rom's SHA matched what was recommended.

ShadowOne333

  • Hero Member
  • *****
  • Posts: 1621
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #630 on: March 04, 2021, 05:04:20 pm »
Narrowed down the issue.
It seems like this particular bug only affected the MMC5 version, since the code for the animation for MMC5 used addresses $0780 up to $0782 (and $0786). With that, and a bit of research, it seems that RAM addresses $0628 up to $062C are unused in the final game, according to Data Crystal (since no other disassembly seems to mention these addresses at all):
http://datacrystal.romhacking.net/wiki/The_Legend_of_Zelda:RAM_map#RAM

So I changed the used addresses to those mentioned ($0628-$062B) and recompiled the MMC5 patch.
Gave a quick test with the saves Chicken Knife posted, and it seems it's all good.
The map glitches some people mentioned could also be related to this, as the issue we had before happened exactly in the same way, and according to Bogaa, addresses starting at $0700 and above seem to be related to map data, so the new v1.01 release could also have fixed those random map glitches.

Already sent the submission, should be up in a few hours.

lexluthermiester

  • Submission Reviewer
  • Hero Member
  • *****
  • Posts: 921
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #631 on: March 04, 2021, 07:53:15 pm »
Update is live.

Chicken Knife

  • Sr. Member
  • ****
  • Posts: 499
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #632 on: March 04, 2021, 10:41:01 pm »
Thank you for working so hard on getting the issue corrected. I have a bit of bad news, however.

The bug that was making the whole screen glitch out seems to be at bay on my save file, but I'm still getting corruption to the map graphics. First some incorrect tiles started appearing to the right of the map, and then the map started having its color palette altered in the lower right section. This is the same bug I was seeing throughout the game. It didn't stop me from enjoying it, but I'm sure you want to see it fixed as well.



You can see the two tiles that shouldn't be there, as well as the graveyard palette showing in the lower right of the map.

ShadowOne333

  • Hero Member
  • *****
  • Posts: 1621
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #633 on: March 05, 2021, 01:05:03 pm »
Thank you for working so hard on getting the issue corrected. I have a bit of bad news, however.

The bug that was making the whole screen glitch out seems to be at bay on my save file, but I'm still getting corruption to the map graphics. First some incorrect tiles started appearing to the right of the map, and then the map started having its color palette altered in the lower right section. This is the same bug I was seeing throughout the game. It didn't stop me from enjoying it, but I'm sure you want to see it fixed as well.



You can see the two tiles that shouldn't be there, as well as the graveyard palette showing in the lower right of the map.

Is the issue reproduceable with the save states you sent previously?
Also, how would I go about reproducing it? What steps did you do to make it occur on your end?

Chicken Knife

  • Sr. Member
  • ****
  • Posts: 499
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #634 on: March 05, 2021, 07:41:01 pm »
Is the issue reproduceable with the save states you sent previously?
Also, how would I go about reproducing it? What steps did you do to make it occur on your end?
Yes, I didn't do anything different in the game prior to having those results. I suggest just loading the save that I sent you. All I did was update to 1.01. To get that result, just start walking randomly around the map.

From the load area, if I walk up, right, up, up, up, up, generally by that section of the map, I start to see odd things happen in the upper part of the screen, generally palette swaps on the map occurring, or other tiles appearing in the black spaces where they shouldn't.

The palette / tile issues that happen vary a little bit each time I do it.

ifightdragons

  • Full Member
  • ***
  • Posts: 153
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #635 on: March 05, 2021, 08:15:43 pm »
Yes, I didn't do anything different in the game prior to having those results. I suggest just loading the save that I sent you. All I did was update to 1.01. To get that result, just start walking randomly around the map.

From the load area, if I walk up, right, up, up, up, up, generally by that section of the map, I start to see odd things happen in the upper part of the screen, generally palette swaps on the map occurring, or other tiles appearing in the black spaces where they shouldn't.

The palette / tile issues that happen vary a little bit each time I do it.

Exactly the same here. I play on original hardware, forgot to mention that earlier.

ShadowOne333

  • Hero Member
  • *****
  • Posts: 1621
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #636 on: March 05, 2021, 09:46:05 pm »
I played for around half an hour, and even did several laps throughout the map, and I couldn't seem to reproduce the bug using the latest v1.0.1 MMC5 version.
If you guys could, could you perhaps test the issue in FCEUX and make frequent save states? Like save each time you get to a new screen or something like that.
Maybe that could help so that when you experience the issue, you could load the previous save state and that could help me reproduce it.

Remember to use the MMC5 patch for this, as I doubt the MMC1 version has the issue (unless I'm wrong, as usual).

Chicken Knife

  • Sr. Member
  • ****
  • Posts: 499
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #637 on: March 05, 2021, 11:02:47 pm »
Very strange that you can't reproduce it. I did as you suggested with FCEUX. It only took me 3 screens to produce the first bugged tile appearing right of the map. It happened between state 1 and state 2 here.

https://www.dropbox.com/sh/ubre9mmif7n4lsr/AADhmzI8ePhYDTrRl3Syxutwa?dl=0

ShadowOne333

  • Hero Member
  • *****
  • Posts: 1621
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #638 on: March 06, 2021, 12:11:05 am »
This is really, really weird.
I STILL cannot reproduce it, not even with the save states.

I load save state #1, walk to the same spot you have in save state #2, and it doesn't trigger for me.
I tried walking like crazy to adjacent screens, and nothing. I just don't get any corruption in the automap.

If you can, could you try doing something for me?
I know the corruption from the save state is causing an extra tile to appear in the PPU, maybe you could try setting a breakpoint and sending/posting a screenshot of what the debugger pops up after the break.

Basically do this:

1) Open the ROM normally,
2) Open FCEUX's Hex Editor by going to Debug -> Hex Editor
3) Once the Hex Editor is open, go to View -> PPU Memory
4) Now, once in the PPU, press Ctrl+G, a little window will open asking you for an offset, type 20DE. That should bring you to the PPU address that corresponds to the area where the corrupted tile appears.
5) In address 0x20DE, do a right click. You should see the option "Add Write Breakpoint to Address 20DE". Click on that one, and the Debugger should automatically pop up, with the game still playing in the background.
6) Now, load your game and try to reproduce the same corruption from the one in your save state (where the extra tile appears next o the automap), or simply walk around until that extra tile appears next to the automap.
7) Once the corrupted tile is set to appear, the Debugger should automatically be brought up to the forefront, and the game will be paused. Take a screenshot of when this happens, specifically of the data in the Debugger.

This is where you should do the right click at (the 24 at 20DE):


That should pretty much give a clear indicator of what is going on.
If you happen to reproduce it, and the breakpoint works and the debugger pops up, send a screenshot of that. That should help a lot!
« Last Edit: March 06, 2021, 12:18:45 am by ShadowOne333 »

Chicken Knife

  • Sr. Member
  • ****
  • Posts: 499
    • View Profile
Re: Zelda 1 Redux / The Legend of Zelda Redux
« Reply #639 on: March 06, 2021, 07:36:16 am »



Here's the debug result. Not sure if you wanted the code above or below so I linked to both. When I loaded the state just before it had popped up previously, it wasn't reproducing this time. I had to walk around for a bit to get the bug to come up again.