11 March 2016 - Forum Rules

Main Menu

Romhack keeps crashing, even with bios

Started by Frederyk Strife, January 14, 2019, 12:32:57 PM

Previous topic - Next topic

Frederyk Strife

So I downloaded a Julius Story mode hack for Castlevania: Aria of Sorrow, but after the introduction text, the emulator says I need a Bios file to continue, but when I try to use a Bios, instead of an error message, the game resets.

Things I've tried:
Using a save instead of starting a new game
-It does work, but the patch knows that I used a later save, and locks stuff

Renaming the ROM to make the emulator think that there is no data
-Same problem

Can someone help me?


Applying a patch to a ROM should not suddenly make it require a BIOS.

Can you please say exactly what emulator you're using, and exactly what the error message says?

Does Castlevania: Aria of Sorrow run properly without the patch?

Also, please try to be more specific when writing subject lines for your posts.
This signature is an illusion and is a trap devisut by Satan. Go ahead dauntlessly! Make rapid progres!

Frederyk Strife

This is my first post, so I'll do better next time,

I'm using visual boy advance for windows and am using the automatic patching

Aria of Sorrow runs fine without the bios, it's just the romhack

The Error message says: "Unsupported BIOS function 20 called from 02081300. A BIOS file is needed in order to get the correct behavior"


Are you using the download from ?

Have you tried running the game without using automatic patching?

Are you sure you have the correct USA version of the ROM?  You should be able to check that the CRC32 is 03B97719 with 7-Zip or whatever other unzipping program you may be using.
This signature is an illusion and is a trap devisut by Satan. Go ahead dauntlessly! Make rapid progres!


While it probably is what Jorpho said that message has me curious so I will leave the following here.

I don't know what VBA is using to number BIOS calls -- 20 in hex is a sound related function, if 20 is in decimal then 14 hex is a compression function, and something a ROM hack is far more likely to touch.

We have seen issues with compression programs not being used properly in the past and it troubling GBA hacks as far as running on hardware, and certain more accurate emulators.

Frederyk Strife

How exactly do I check to see if I have the correct USA version?

I am using the latest release of the hack in the link.

Do you think by manually patching the game with a program, instead of letting VBA do it would fix the problem?

Frederyk Strife


Your problem has been solved, but I just wanted to add that you are probably using mednafen and its soft patching is broken. I don't know if it has been fixed by now.