News: 11 March 2016 - Forum Rules

Author Topic: So, I think I messed up, BIG TIME (SMB: F7N8 tiles) or SMB ? Block error  (Read 3158 times)

GlitchyTSP

  • Jr. Member
  • **
  • Posts: 20
    • View Profile
So, what happened was I was editing ? block Palette to better match the ground tiles Palette, however, when I did that not only did the question block stop blinking,(cycling Palette's) but every few Screens, one of these appear.

https://media.giphy.com/media/5nor3pjvtqF2KRvLV9/giphy.gif


My current emulator is FCEUX 2.2.4,
I was using an old version of NES Palette (I've since upgraded to a newer version)
and I'm using SMB Utility to edit the levels


What's even weirder still is that in SMB Utility's built-in emulator these dont appear.

Lenophis

  • Discord Staff
  • Hero Member
  • *****
  • Posts: 971
  • The return of the sombrero!
    • View Profile
    • Slick Productions
Re: So, I think I messed up, BIG TIME (SMB: F7N8 tiles) or SMB ? Block error
« Reply #1 on: November 14, 2018, 11:12:03 am »
You're probably seeing it now because you're using more-accurate emulators. The best way to determine if what you are seeing now is a result of it, open it up in high-accuracy emulators. (Bizhawk I guess, Nintendulator, puNES, hardware if you can). If it's showing up there, then you know you have a problem.

It's also possible that the upgraded version of NES Palette caused an incompatibility issue. You may need to start over. Try undoing some changes, or restoring a backup, to see when the problem originated.

What's even weirder still is that in SMB Utility's built-in emulator these dont appear.
What emulator is it? More than likely it's out of date. Don't trust it. Use maintained emulators.


https://ff6randomizer.codeplex.com/ - Randomize your FF6 experience!

GlitchyTSP

  • Jr. Member
  • **
  • Posts: 20
    • View Profile
Re: So, I think I messed up, BIG TIME (SMB: F7N8 tiles) or SMB ? Block error
« Reply #2 on: November 14, 2018, 11:22:12 am »
Well, i have noidea what emulator SMBUtlity uses, sorry.

I will try high accuracy emulators and see if it changes anything,

As for startingover, im currently trying to do that (or rather start from ver 0.1) but im not sure if thats the sulotion, since as far as i can tell theres no SMB level importing techniqe, if there is please point me towards it.