Problem building PS1 disc image with uncompressed audio file (SOLVED)

Started by acediez, May 15, 2018, 10:45:12 AM

Previous topic - Next topic


I'm using mkpsxiso to rebuild a PS1 game (changed several files for bigger ones), and everything works fine except a single audio file that doesn't play in-game.

The game is Mega Man 8, the file is the ending song, located in the root of the data track as "END1.DA". When extracted, this file plays as a regular uncompressed WAV file. (It's probably worth noting that the game has separate CDDA  audio tracks for the rest of its music).

When rebuilding my disc using mkpsxiso and set this track as a data type, the song isn't played ingame (it stays completely silent).

If I look at the original disc on CDmage, the track has the FM flag, the same one STR and XA files have.
So naturally I tried to rebuild the disc with the track set as XA. It didn't play ingame either.

I tried both file types on mkpsxiso, and both extracting the DA file as a regular file (extracted with CDmage, playable as a wav file), and as if it were a XA audio file (extracted with XtrActor by reported LBA/size, unplayable as a wav file). None of those four scenarios played the music in-game.

If, using CDmage, I load the ORIGINAL game, and replace this audio file with a different  wav file, renamed ("import file"), the new file is  correctly loaded and plays in game!
However, if I try the same with my mkpsxiso modified build with said file defined as XA type, CDmage doesn't let me replace it ("file must have CD-XA format")  even though it's the same renamed wav file that works on the original.
This leads me to the conclusion this file is neither a data track or a regular XA audio file.

How can I correctly rebuild a disc image that has such an audio file?
If this is a special case mkpsxiso won't be able to handle, is there a way I can identify correctly and cleanly "cut and paste" from the original disc the specific section that deals with this file?

Still, it's entirely possible that there's something else preventing the sound file from playing, but the file is referenced on the in-game TOC and it's being correctly re-allocated, as is the rest of the game. I confirmed this because when the game can't find the file (if I purposely write a wrong LBA for the file) the ending credits "scene" doesn't even load.

Any lead would be very appreciated! Thanks!

EDIT: It was, indeed, a different kind of audio track. I asked mkpsxiso's author about it, and he immediately added support for it!