Snes emulators (Canoe, Snes9x) -- game problems and fixes

Started by sluffy, February 10, 2018, 11:25:45 PM

Previous topic - Next topic


Quote from: Bosco82 on November 30, 2020, 05:03:11 PM
Patch this on top of the LTTP patch

thanks! it seems to be working now! you're really good at making these patches work  ;D
free sluffy


I found this Super Ultra Baseball 2 prototype, and it runs on Canoe, but it has overscan issues. Is there any way to fix this?
free sluffy


Sorry to necromance this thread but it really seems like the most appropriate place to ask this.

So one of the biggest glitches that was attempted to be fixed was the touch fuzzy get dizzy background glitch in Yoshi's Island. I know the background glitch never got fixed, but when adding a rom of Yoshi's Island to my classic I noticed that the top row of pixels would flash, similar problem that FF Mystic Quest and Marvel Super Heroes had something to do with h-blank.

"Similar concept to Mystic Quest. Wait for h-blank and try to turn screen on in-time before next scanline begin"

This screen flickering occurs with both the 1.0 and 1.1 versions of the rom, as well as with a preset id or not, patches or no patches. Did anyone else notice this screen flickering on top row of pixels when using any Yoshi's Island rom? It seems like a problem that would have been patched in the early days of this thread, I'm just really surprised I can't find a canoe patch for it since there was such a push to fix the fuzzy background layer issue but no one brought this up.

Does anyone have a copy of a patch that fixes this screen flickering issue for Yoshi's Island? It's distracting enough for me that I rather play with the stock canoe rom with crying baby mario, than use an added rom with the crying removed but flickering present, and that says something lol.

Thanks for the help.


It seems I've already heard your flickering issue when using another rom (than the one provided in stock) of Yoshi's island. I don't know why this issue is not present with the stock game (i.e, the use of a sligthly modified rom by nintendo ?), but you should try some things anyway :

- Firt, try the correct preset ID 123D (or 3D12 in old hakchi versions)
- Second, by chance, try to convert your rom with SFROM Tool (and also use 123D)
- Third, be sure you didn't have put a different core than canoe to launch your game. This flickering issue seems to be known with the use of snes9x until 1.43 version : probably retroarch + snes9x 2005 lead to this also.


Quote from: sluffy on March 18, 2018, 10:19:03 PM

Shift Yogi Bear 1px up/down. Not sure which way, since snes9x shows black for all 3. (yogi1a = should be winner) (yogi1b = glitches bsnes+)

Gday, can some cool dude please put up a link to a "Adventurs of Yogi Bear" SNES Rom that has been fixed (MOD: I'm sure you mean patch, no ROM links), so that it loads past the pre-start menu ?

Also, if anyone has a Batman - Revenge of the Joker that works, that would be swell. Can't get either to work


A note regarding Super R-type on the SNES Classic for any people who prefer Canoe like I do: Vitor Vilela's SA-1 hack for the game works on Canoe without loading glitchy graphics on save states, unlike the Contra III and Gradius III ones! (Set the preset ID to 109C) There is a caveat, though - when starting a new game after having created a battery save on it, sometimes your ship will appear on the title screen and the game will softlock to a black screen if you press start. The only thing I've found that works is to fly your ship around the title screen and try to crash into something. Usually doing this and pressing start will allow you to begin a new game.

There are also multiple fastrom hacks for SNES - you can find most of them by searching for "fastrom" under hacks on Every single one I've tried works without issue in Canoe, while Super R-type remains the only SA-1 hack I've tried that save states will worth with in Canoe. Here's a Gradius III fastrom patch that works with Canoe (courtesy of slidelljohn and Aaendi):

In addition, the SNES port of Mega Man 4 works in Canoe without issues.


I'm curious to dissect the changes made into EB from the emulator side, but I don't know exactly how to get the hang of the binary's code.
hello dear



Hi Mate,
recently i've modifidied snes mini pal with Hakchi 3.9.3 and added a 32GB Memory card. I've putted more roms but some doesn't load with canoe, follow:
Hammering Harry
Quick The Rabbit
Mick & Mack Global Gladiators
Mr. Blooby
Xmen vs Street Fighter Pirate
King of Fighters 2000 Pirate.
and some other that i've forgot
thank you in advance


Was there ever a fix for Smash Tennis? It's included in the SNES library on the Switch now.


Looks like the great Sluffy is back, he has post recently a bugfix patch for Rendering Ranger R2:   ::)


No, sluffy's not back, someone else just uploaded his Rendering Ranger Canoe fix patch that's been available for years.


Quote from: Samus12345 on May 16, 2022, 04:38:41 PM
No, sluffy's not back, someone else just uploaded his Rendering Ranger Canoe fix patch that's been available for years.
Sorry about the mistake you are right, i have just seen the patch has been submited by other user called Aberu  :(


A request if anyone with the skills still follows this thread: Shounen Ninja Sasuke has overscan when loading a save state, like Combatribes does (which got a patch). Anyone willing/able to fix it? Thanks!

EDIT: I think I fixed it:

If anyone tries it and it's not fixed, let me know.


Was there ever a patch for the Lobo prototype?