News: 11 March 2016 - Forum Rules
Current Moderators - DarkSol, KingMike, MathOnNapkins, Azkadellia, Danke

Author Topic: ASM hacking tutorial problem  (Read 913 times)

SleepyFist

  • Hero Member
  • *****
  • Posts: 826
    • View Profile
ASM hacking tutorial problem
« on: February 11, 2016, 11:50:13 am »
This morning I wandered off task and found a tutorial on how to hack the Spindash from Sonic 2 into Sonic 1.
http://info.sonicretro.org/SCHG_How-to:Add_Spin_Dash_to_Sonic_1/Part_1
Followed all the instructions more or less, built ROM, loaded in KEGA and nothing, so I tried removing the additional code from the ASM file and tried again but still nothing, Got a fresh copy of the disassembly and tried again with no changes, still getting blackscreen in KEGA.

So can someone investigate and tell me what Im doing wrong?
Ill keep at it see if I can get it to function in the meantime.
Im really hoping its not another one of those damn Win10 incompatibilities rearing its head again.

Edit:Methinks maybe it has less to do with the actual disassembly and more to do with either the batch file or an incompatibility in one of the programs used in the build, so far messing with the batch hasn't turned up any results though.
« Last Edit: February 12, 2016, 08:36:48 pm by SleepyFist »
Sleepy's tune of the week|| Lost Lullabies (Unreleased Samurai Champloo tracks)|| https://youtu.be/BK6PR8DPNOw