Is there a save file patch for the Super Robot Wars J translation?

Started by Antares, April 20, 2014, 11:00:44 PM

Previous topic - Next topic

Antares

You are unable to actually load any saves in the translation, so I was wondering if there's a patch somewhere out there that fixes this.

Bonesy


Antares

Quote from: Isao Kronos on April 21, 2014, 01:34:15 AM
Check your emulator settings.

Could you be more specific? Is there a setting I need to change that doesn't require to start a new game?

Scio

Is the save file the same name as the ROM? (example: SRWJ.gba and SRWJ.sav?)

Your problem is that the save doesn't even appear on the menu, or that the game saves, but when you restart the emulator, the save disappears? If it's the latter, there should be an option called "Update SRAM when exiting" or something to that effect. You can also force a manual SRAM update.

Antares

Yes, same file names. When I go to save during intermission, the save shows up in the confirmation screen, but when I reset, the save disappears. The only thing I found was an option to change the save type. The default is Automatic, and I changed it to SRAM and then to Flash, neither worked.

Scio

I had that problem with a few emulators in the past. I once lost 13 hours of progress in a Pokémon game because of that.

See if the save file (.sav) isn't write-protected. What emulator are you using?

Antares

The read-only checkbox isn't checked, so it's not write-protected, right? I'm using VisualBoyAdvance.

Scio

I did some tests here, and these are my configs:
- VBA 1.8.0
- Save Type: Automatic
- Flash Type: 64k

The game saved fine. Which makes me think there's only one thing that could be the problem... you're not using save states, are you?

Bonesy

I use VBA-M and I've never had any problems loading a save.

Scio

I asked about save states because it's not a good idea to mix battery saves with them.

Bonesy


tc

Quote from: Isao Kronos on April 22, 2014, 03:09:55 AM
who the bollocks told you that

Some emulators when loading a save state, replace your save file with the one from the save state.

Bonesy


Antares

Quote from: Scio on April 22, 2014, 01:54:51 AM
I did some tests here, and these are my configs:
- VBA 1.8.0
- Save Type: Automatic
- Flash Type: 64k

The game saved fine. Which makes me think there's only one thing that could be the problem... you're not using save states, are you?

I'm using beta 3, and the emulator was originally set to Flash type 128k. I changed it to 64k, saved, and reset... Still the same problem.

I do use save states and have never had a problem with them interfering with the save file. I read somewhere if I change from 128k to 64k, I'm going to have to erase the save data and start a new game for the change to take effect. No idea if there's any truth to this, but is there anything else that could be affecting the saving?