News: 11 March 2016 - Forum Rules
Current Moderators - DarkSol, KingMike, MathOnNapkins, Azkadellia, Danke

Author Topic: PKMN Diamond (U) translation-script problem  (Read 1591 times)

raykyogrou0

  • Guest
PKMN Diamond (U) translation-script problem
« on: April 03, 2013, 08:02:30 am »
So, I'm kind of new to scripting.  I'm basically trying to translate pokemon diamond into my own language.
And, bam, the first text I translate messes up a script (I'm guessing).
It's the script of when you go to meet Barry (the main rival) for the first time.  The door opens and instead of him coming out and bumping into the player, nothing happens, it basically freezes up because everything is locked (music still on, buttons just won't do anything). :banghead:
I'm using PPRE's map editor, and edited map 441 (Twinleaf Town).
I translated all the text and the other scripts are working fine (the fat guy talking about technology, the girl talking about pkmn friends, the house signs).  I tried leaving out the text for that script unedited, it still freezes.  When I tried to put the original text back, it still freezes.  It only unfreezes when I get the original ROM and unpack it again (after deleting the old files from the tmp folder).

It's this script (3):
Quote
Lockall
PrpDoorAnm 3 27 9 11 77
Opendoor 77
Waitaction 77
Clearflag 402
Addpeople 2
Applymovement 2 mov_2
Applymovement 255 mov_3
Waitmovement
Fanfare 1538
Message 0
Return 30 0x800c
Callstd 250 7
Applymovement 2 mov_4
Waitmovement
Setvarrival 0
Setvarhero 1
Message 1
CloseMsgOnKeyPress
Applymovement 255 mov_5
Applymovement 2 mov_6
Waitmovement
Return 15 0x800c
Setvarrival 0
Message 2
CloseMsgOnKeyPress
Applymovement 2 mov_7
Waitmovement
Closedoor 77
Waitaction 77
Waitclose 77
Removepeople 2
Callstd 251 7
Setvar 0x4070 1
Setvar 0x40e6 1
Releaseall
End


It seems when I delete the entire contents of the script and press 'save' it copies over the script from the fat guy talking about technology except I don't press "A" to talk to him.  I walk in the square, the message pops up, I can click it away with A and it never happens again. 

Does anybody know how to fix this?  Yes, I checked if the script changes at all before or after translation and no it doesn't.

Also, where can I find and edit the text where you change the menu (you know, pokedex, pokemon, bag, trainer, save, options, exit)?  I found a new version of ppre, PPRE2, and used its text editor and its amazing find function but I can't save shit with this.  I click save this, save that and no file gets created.

Thanks, and your help is greatly appreciated :thumbsup: