Castlevania II (Simon's Quest) - Multilingual enhancement

Started by Bisqwit, December 19, 2012, 01:38:36 PM

Previous topic - Next topic


I finally took my time to build the repro of this translation.
It's working just fine, but I want to add battery backup and I have some little questions:
- If I use a 2kB chip like the 6116, will I have enough room for at least 3 saves?
- Should I implement some kind of SRAM protection on hardware level (eg. disable the RAM when ROM is enabled )?
- Should I post pictures of the project, since I'm using a Super Sprint board? It may be a nice reference, since I'm doing a UOROM repro.

Again, thanks for this great work!


Saves are 256 bytes in size, so yes, your chip will do just fine, assuming its signal characteristics are otherwise suitable for a Famicom/NES cartridge. No SRAM protection is needed (if I understand the implications of your question correctly), just make sure it responds only to requests in $6000-$7FFF range. ($0000-$7FFF is fine I think, so really only bit 15 matters.)
Yes, I would like to see pictures. :-)


Thanks for the info!!
Looks like I just can't attach any file here, so, here's my Google drive's links:

I'll add more images as soon as I add the save RAM.

I know a veroboard would be nicer... but even I pay 30 bucks and buy in my city or buy some for cents and waited around 3+ months for it to arrive from China :-)


Comment removed.




I don't know if I've found a software bug or if this is caused by some problem on my cartridge's wiring.
Actual pictures of the board:
Sorry about the bad pics, but my fluorescent light gives me this result :-(

The save/load screen does not show the cursor on the save/load/cancel options, neither when asking if I'm sure I want to save.
The slots on the screen also jumps a little, ocasionally I have some slots that had saved content marked as void or damaged. If I stay too much time on the save screen, the game crashes.

I had not tried this on an emulator yet, but I asked about the circuit I've build on NesDev and the logic seems to be correct.
Although I had not time to play the game to the end, with exception of the save/load routine everything else seems just fine. Did anyone tried a similar configuration (mapper2 +Save RAM) on real cartridge?
Anyway, I bid you shalom too my friend and ask for help to try to fix this. :-)
Thanks in advance!

PS.: Although it's cool to find that you have a friend that also posts on RHDN, it's a little off when you borrow his PC and post something on his login.
Could the moderator please delete the last Decerebrado's post?
Thanks in advance!

September 07, 2016, 06:47:23 PM - (Auto Merged - Double Posts are not allowed before 7 days.)

Hope this can clarify a little:
Could you please help me debug this?
Thanks in advance!


Fisher, there is something odd with the sounds in your footage. It is not a good NES emulator. A bad emulator may be the cause of the problems you reported, too.

In other news, I made this video that explores the password scheme of the game! Thought of sharing it here.


Well, I'm trying to do a repro, on real hadrware, well... cloned, but real. :laugh:
The footage mas made with an old NES clone from around 1991, just like this one:
It had played all games I've throwed in so far, including Castlevania 3.
AFAIK, it has two sound channels inverted, and the audio output is really noisy!

The capture card is an old Pixelview USB 2.0, very cheap, so I don't expect to capture anything better than that on it.
I really suspect the SRAM I've got is defective, this would explain the disappearing saves, but would this be enough to make the game crash?
By the way, very nice video!! Pretty clear explanation!!


Quote from: Decerebrado on July 24, 2016, 09:50:58 PM

I'm having trouble trying to create a patch with the vending machine, I would like a patch in english, NTSC, with MMC1, No CHR-ROM, SRAM saving and password support. The other options are the vending machine's default ones.
Could you please generate this to me?
Thanks in advance!!

Same as me. Can not play with MMC1 no CHR patch.


Kudos to Bisqwit. Will you add the FDS version music compatibility (Dracula II) in Multilingual Enhancement? I know that the FDS had different music than the NES one.


Quote from: Bisqwit on December 19, 2012, 01:38:36 PM
-- : 2016-03-02 (dialog updates, performance upgrades)
-- : 2016-03-11 (fixed crash & data corruption bugs)
In these versions after cinematic trailer appears a square of Malevich.


There are some issues with the patcher on your page:

-UPS zip and BPS zip are broken and don't work (give 404 errors)
-UPS no-archive and BPS no-archive don't seem to open a download prompt at all in Chrome; very odd
-UPS and BPS seem to download fine when selecting gz archive format, but the resulting archive has blank zero-byte files (nothing in them)
-Using the IPS file in a zip archive in MM4 format, downloaded and patched to an original perfect-dump rom matching the proper hashes, there is a black screen freeze after the intro sequence concludes.  This does not happen if the sequence is skipped by pressing start at the title screen.


Also confirming the black screen freeze at the end of the opening on v.


Quote from: Bisqwit on July 27, 2016, 09:49:34 PMThe patch generator may be broken again. For what reason I don't know. Stand by while I'll investigate it.
Note to self: Remember to followup on this promise.


Hello Bisqwit, I was wondering if you had a chance to investigate the issue with the latest patch, which has a black screen after the intro ends, needing a reset to get back into the game. Thank you very much!


in the patch generator If select 'blink Simon when invulnerable' /no the the blinking thing is always enabled


new intro sequence is great but it gives black screen on the end where you can do nothing. when you break intro by pressing start it promp title screen again (so its good) but it wont prompt title screen when you watch entire intro. can it be fixed ?
many thank for your hard work ;)


Hi Bisqvit

CV2 together with Zelda II were great games to me in the 80s but like so many others I had my gripes with the former. ;) Love the effort you put into bettering the game.
But one thing that puzzled me were the ending screens. I just could not make sense of them.
Then today I saw Cinemassacre's playthrough of it ( they also mention your work ) that the ending scenes might have been messed up. Either by mistake or like some bizarre type of joke. James Rolfe and Mike Matei discuss this at the end of the video.
Any hints that they might be right about this in the code you analysed?

Anyway, this thread deserves to be kept alive seeing how this is the best effort ever on making Castlevania II into the classic it was SUPPOSED to be!



Quote from: Pancio on July 30, 2017, 04:27:11 AM
new intro sequence is great but it gives black screen on the end where you can do nothing. when you break intro by pressing start it promp title screen again (so its good) but it wont prompt title screen when you watch entire intro. can it be fixed ?
many thank for your hard work ;)

I noticed this glitch as well. It messes things up when your trying to create a movie file.
If the start button isn't pressed just at the right moment, It goes black and freezes.
A cool thing to do would be after the intro completes for the game to go directly to the Start, Password, Load Screen.


Is it possible to get a version where the title screen stays the same? No html links?