11 March 2016 - Forum Rules

Main Menu

Final Fantasy VII NES Project (Completed!)

Started by Lugia2009, April 08, 2011, 12:22:37 PM

Previous topic - Next topic


Congrats on completing the project, I can't wait to play!!  :thumbsup: :woot!: :crazy: :beer:

However, I just tried patching a clean Final Fantasy VII (C).nes with the English patch version you supplied, and it didn't do anything...


Somethings up with the patches because I too am having issues. BTW whats the recommended emulator for this? FCEUX?


Ok, I fixed it.  Sorry for the problem.  :-[

Here's the download link for the fixed patches:

I also resubmitted it to the database, and posted it on the first page.

The emulator I've been using is FCEUX for the PC.
NesterP for the PSP and FCEUX for the Wii also work well.


Using FCEUX as well, the menus and everything now work with your latest patch, but the first battle makes a black screen and hangs.

EDIT: never mind seems to work, I was a bit confused with the extra patches in the file, no need to patch it to english I guess.


Nice to see your completed this project.  :thumbsup:

Its time for a replay of FFVII but for the NES this time for me. Thanks.



Congrats! I've been watching this thread forever and can't wait to finally play this!





I've just registered in to provide a feedback for your patches. I have some trouble to patch the game:

Applying the patch on the Chinese version:
Applying the patch on Lindblum's translation:

I checked the CRC32 for the Chinese file, it is the correct one.
patched the files via Lunar IPS or Ninja, same result.

What did I do wrong?

Never mind, just saw a newer version


WTH is mapper 163, which seems to be the only thing unsupported by Vitual NES? And, yes, I DO have FCEUX, but I hate its chipmunk singing whenever I use maximum throttle


Congrats on completion. I shall investigate this when I have the chance, man.  :beer:


Congrats on the latest release Lugia. I've been keeping up with this project for a long time now, and it's always good to see something get completed and not just left behind to collect dust unfinished, especially something so epic. Has anyone been able to get this to run on Xbox though? I'm using NestopiaX, and tested the original rom first, then tested the english patch from your dropbox link a few posts above and they both worked, then patched the original rom with your actual patch, but it won't load at all. Just curious if anyone knows why or of an Xbox emulator that would load this correctly?


Can not wait to play it next week <3<3

Kiyoshi Aman

Just for the record, if you are downloading from RHDN, the fixed patch hasn't been approved yet due to technical difficulties. In the meantime, please use the Dropbox download link provided earlier in the thread.

We apologize for the inconvenience and are working as fast as we can to resolve the problem.


Amazing, i'm playing it on RetroArch for the Wii.

Looking foward pocket monster yellow nes. :)


OK, turns out VirtuaNES has not got an update in aeons, BUT there is a "modded source" named VirtuaNES Plus, that works with this but with minor graphic bugs on the first row of the screen. Nothing worth worrying about.


 :thumbsup:Just wanted to say great job after all the hard work and thanks for sharing with all us folks :angel:


You did it! Well done!  ;)
I'll play it when I get home, thanks :)


I thought this was a cool idea from the first time I came to the thread. It's so wonderful that you've been working so steady and true and the project has come to fruition.

Congratulations, congratulations, and congratulations!

"May you live happily forever!"

~ Double Dragon


hey luiga! great job! is there any way to get this to work on nestopia for pc? I did download the patch from the correct link you reposted earlier.