News:

11 March 2016 - Forum Rules

Main Menu

Legend of Zelda... compressed graphics?

Started by Reaper Man, February 22, 2011, 05:19:28 AM

Previous topic - Next topic

Reaper Man

Okay, so I've looked at the LoZ rom and I can't help but notice that there are what looks to be RLE encoded graphics tiles, but I could be wrong.  Is there a complete map of where the graphics are in this game?  I kinda need to know for my rom corruption project.


Reaper Man

sounds great, cept for the fact that said document is for A Link to the Past, and not for the original NES game.

Azkadellia

Current Projects: On hold indefinitely.
I do the Twitter thing now: https://twitter.com/MistressSaeko (expect lots of game streaming announcements)
Mistress of the RHDN Discord server.

Reaper Man

#4
Yeah I saw that, but the ROM map looks a bit incomplete.

I'm probably going to open the ROM up again and compare addresses and see if the locations I'm wondering about are defined in the map.

February 22, 2011, 07:56:55 AM - (Auto Merged - Double Posts are not allowed before 7 days.)

I took another look.  Apparently, LoZ has some really fucking strange graphics offsets which to me looked like some odd compression, as my graphics viewer wasn't aligned.

What still puzzles me is what the hell is the data located around 0x1C000?  Anyone know?

never-obsolete

The game uses chr-ram, so they aren't exactly aligned in rom. Offset them by a few bytes here or there and they should show up correctly.

The data starting at 0x1C000 are DMC samples. The first one is used for the sword sound fx. I'm not sure where the samples end or what chunk of data is for what sound.

Here's an incomplete dissassembly if it will be of any help.

Reaper Man

Ah, so that's what it is.  I guess I could corrupt that too, but it probably won't do too much.

As for the disassembly, I won't need it for what I'm doing.  Thanks anyway.