News: 11 March 2016 - Forum Rules
Current Moderators - DarkSol, KingMike, MathOnNapkins, Azkadellia, Danke

Author Topic: Translation Hacking Font Issues  (Read 2758 times)

Goveynetcom

  • Jr. Member
  • **
  • Posts: 47
  • Mad Man
    • View Profile
Translation Hacking Font Issues
« on: January 15, 2011, 06:47:25 pm »
Hey guys, been a while since I posted here.
Well I decided to work on a couple new translation projects, I am just working on getting the base lines of the hack work done or figured out.
Here's my problem, I'm still relatively new to the whole overhaul of a rom in translation hacking. So I'm trying to dump the scripts of a couple FDS roms. And I just can't seem to get my hexeditor to properly view my table with Japanese characters. I'm using WindHex, and I just can't get the damn thing to view my table. Well after a bit of stupidity, I realized that it was trying to view my foreign characters in ANSI so I switched the flag for Unicode. Some of them display, but for example I couldn't get any of the normal width katakana characters to view, it would just show the half-width ones. I'm just gonna assume this either a font issue or an encoding issue that I'm not aware of.

Is there a guide to help me get this setup? Or any pointers or etc.?
Thanks for any help you can provide.
EDIT:
Well it was just an encoding issue, ditched notepad (which I should have done since the beginning but I am lazy ; ; ) and switched too Notepad++ which allowed me to change the character encoding to Shift-JIS. Seems to be working fine now. I'll post if I run into any other issues though.
« Last Edit: January 15, 2011, 07:29:20 pm by Goveynetcom »