News: 11 March 2016 - Forum Rules
Current Moderators - DarkSol, KingMike, MathOnNapkins, Azkadellia, Danke

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Fcoughlin

Pages: [1]
1
Hi all,

So I decided today to work on a rom hack for Zelda Ii on NES, in which the dungeons are all placed in a row and only bosses are available (allowing you to just fight the bosses/decide on your experience). I had good success on emulator (FCEUX).

However, a few friends loaded their copies onto emulator, and the graphics in levels 4/5/7 were messed up notably as seen in this playthrough:  https://youtu.be/xcis0bmVZyo. Specifically, 4's background was very off, Gooma clearly had the wrong Sprite set loaded, as did most stuff in the Great Palace. Of course, it's annoying because I loaded it on my emulator, and it still works ok.

So my question: has anyone encountered this before (ideally with this game), and if so, do you have any suggestions on how to fix? I am half wondering if there is some uninitialized memory stuff going on, and hitting a pointer that in FCEUX works ok, but fails in the powerpak.

It could also (in the case of level 4) have to do with the fact that I tried to move it to West Hyrule (instead of Maze Island). Again, it was conveniently working on my emulator so who knows?

Either way, I figured I'd ask, hoping someone has seen something similar before. Thanks in advance for any help you may have!

2
ROM Hacking Discussion / Super Mario 3 - Pipes to Death?
« on: March 23, 2015, 09:15:19 am »
Hi all,

I was working a bit on a ROMhack for Super Mario 3.  I was going to start with the very simple "change memory addresses to move some levels around".  So I remapped 5-5 ( http://www.nesmaps.com/maps/SuperMarioBrothers3/SuperMarioBros3Map5-5.html ) to 1-5 (among others).  Most of the other changes have worked OK, but for the pipe in 5-5 where you normally go into the room for the Tanooki suit, something is not properly loading:

https://youtu.be/V_1XAII2D5w

To make this change, I went into the Pointers Table.  I specifically changed the Object Set, Enemy Data, and the Object Data addresses for the levels.  For most other levels it has worked, but that one room is trouble (it also showed up moving 7 - Fortress 1  which has the same room type:  http://www.nesmaps.com/maps/SuperMarioBrothers3/SuperMarioBros3Map7MiniFortress1.html).  It's possible I'm loading something incorrectly, but thus far this is one of the only places that is causing this.

Has anyone encountered this before?  If so, do you know what's causing it?  I've been trying to look into this, but with incredibly limited success thus far.

Thanks in advance!


3
ROM Hacking Discussion / Mega Man 5 - Questions
« on: March 19, 2015, 11:07:25 am »
Hi all,

So I just started looking into Mega Man 5 for some possible alterations.  I went through the ROM Map posted on the site, learned about Enemy/Object IDs, etc.  So one of the changes I wanted to play with was switching bosses around (so you walk into Star Man's boss room, for example, and you run into Stone Man... yes I realize there are Palette issues and other things, but I'm just trying some basics).  By simply changing the enemy info, I am successfully able to make Stone Man drop into the room.  However, Stone Man then gets stuck in a loop of doing his entry animation, and not actually starting the fight.  I'm guessing this is due to not being able to properly find a pointer to Stone Man's AI, or something similar.  Has anyone tried doing something like this, and if so, do you know what's causing this?

Thanks in advance!
Fred

Pages: [1]