Romhacking.net

Romhacking => ROM Hacking Discussion => Topic started by: duke24e on September 04, 2019, 09:22:44 pm

Title: zelda2 palette hacking question
Post by: duke24e on September 04, 2019, 09:22:44 pm
Hi everyone, does someone know how I can change the color of first palace ? not where we begin but in the desert ? without changing the color of the palace we begin ?

I would like something more dark, keeping the gray color but more dark, it is possible ?

thanks.
Title: Re: zelda2 palette hacking question
Post by: GTM604 on September 07, 2019, 08:42:11 am
Hi Duke, I use this editor it's super easy just load the game into the editor in the top left corner choose edit then palette editor use the drop down bar and choose palaces inside then go ham

https://github.com/cfrantz/z2edit/releases/tag/v1.0.22
Title: Re: zelda2 palette hacking question
Post by: duke24e on September 08, 2019, 06:19:28 pm
Hi Duke, I use this editor it's super easy just load the game into the editor in the top left corner choose edit then palette editor use the drop down bar and choose palaces inside then go ham

https://github.com/cfrantz/z2edit/releases/tag/v1.0.22

Thanks :) it work very well.

I have another issue, I changed to color of palace no 5 but the falling block are still green until they hit the ground, when hitting ground the color change to the color of the ground. Do you know how to fix this ?
Title: Re: zelda2 palette hacking question
Post by: Cyneprepou4uk on September 08, 2019, 07:22:32 pm
How about posting some screenshots, will ya?

Sounds like a 16x16 background palette attribute issue.

Also, was there really a need for creating a new topic instead of using this (http://www.romhacking.net/forum/index.php?topic=29168.0) one? I think its name pretty much allows you to ask any zelda hacking questions. Are you going to create a topic every time you encounter yet another problem in zelda?
Title: Re: zelda2 palette hacking question
Post by: duke24e on September 10, 2019, 07:20:39 am
How about posting some screenshots, will ya?

Sounds like a 16x16 background palette attribute issue.

Also, was there really a need for creating a new topic instead of using this (http://www.romhacking.net/forum/index.php?topic=29168.0) one? I think its name pretty much allows you to ask any zelda hacking questions. Are you going to create a topic every time you encounter yet another problem in zelda?

Thanks, I will post a screenshot in my other post :)