News: 11 March 2016 - Forum Rules
Current Moderators - DarkSol, KingMike, MathOnNapkins, Azkadellia, Danke

Author Topic: Retro-Bit controllers for Mega Drive / Genesis MODE button functions differently  (Read 802 times)

RetroProf

  • Full Member
  • ***
  • Posts: 137
    • View Profile
Not sure where to post this. But it might be interesting for some people. This only pertains to the controllers for original hardware, not the Mini console.

Retro-Bit manufactures licensed 6 button controllers for the Mega Drive / Genesis, using shell casts from Sega and, allegedly, with the exact same component build quality. They're pretty good.

However, I found that the MODE button does not function the same as on the original 6 button controllers from back in the day.

I have several of each and have been testing them.

On games like Lost Vikings and Techno Clash the MODE button on the Retro-Bit controllers functions as you'd expect. Accessing the menu or activating the healing spell. However, when used with MIJET's patch for Shinobi III, to access the 6 button mode for the game, the MODE button does nothing.

At first I thought maybe I applied the patch wrong, or it was my Mega Everdrive Pro not working correctly. But when I switched to my old 6 button controller from the 1990s, the MODE button worked correctly.

I cannot for the life of me figure out why the MODE button on the new Retro-Bit controllers functions differently to the older controllers. It works, as evidenced by Lost Vikings and Techno Clash, but for some reason it does not work with Shinobi III, only the old original controller works.

I'm not too fussed about this getting fixed with patches. I have five controllers for my system, so I'm good for options.

But I'm just curious. Like, why? And how? And how come it's not the same for all games?

Thought someone might find it interesting to know.