News: 11 March 2016 - Forum Rules
Current Moderators - DarkSol, KingMike, MathOnNapkins, Azkadellia, Danke

Author Topic: Confused on battle of olympus graphics  (Read 1819 times)

Xdegenerate

  • Jr. Member
  • **
  • Posts: 21
    • View Profile
Confused on battle of olympus graphics
« on: May 25, 2019, 01:24:11 pm »
I wanted to sub Morpheus graphics for Link (Zelda II) on nes.

However it's become a much harder task than I thought.

Whenever I change the graphic, it shows up in game all scrambled up. The thing is what tile editor pro shows as his head graphics, isn't the same as what's appearing in the game. It's kind of all one color, where as in game it's showing more colors to his palette.

I'm not talking about the palette colors not looking the same as the game in TEP, I mean it's more like it's not as it looks in game. The tile for the head in TEP pro shows his color for the jewels on his crown thing are transparent, where as in game they are blue.

Is there something I'm missing here?

The other weird thing is it's showing other pixels in the head tiles graphics of the character
like it's part of the background, when it should just be transparent. It's not coding or something in it, in the actual sprite tile?

#

  • Full Member
  • ***
  • Posts: 179
    • View Profile
Re: Confused on battle of olympus graphics
« Reply #1 on: May 25, 2019, 07:22:09 pm »
The graphics of Battle of Olympus are compressed. But as luck will have it someone made a (de)compression utility for the game: http://www.romhacking.net/utilities/1395/

Xdegenerate

  • Jr. Member
  • **
  • Posts: 21
    • View Profile
Re: Confused on battle of olympus graphics
« Reply #2 on: May 26, 2019, 07:15:00 am »
Cool. Thanks! I'll see if I can get my head around it and try it!

May 27, 2019, 07:15:04 am - (Auto Merged - Double Posts are not allowed before 7 days.)
The graphics of Battle of Olympus are compressed. But as luck will have it someone made a (de)compression utility for the game: http://www.romhacking.net/utilities/1395/

Euhh, I tried. I cant work it out. I dumped a .bin file and it looked all weird in TEP. I have no idea how to specifically find the graphics needed to change.
« Last Edit: May 27, 2019, 07:15:04 am by Xdegenerate »