News: 11 March 2016 - Forum Rules, Mobile Version
Current Moderators - DarkSol, KingMike, MathOnNapkins, Azkadellia

Author Topic: Tile Molester GUI Problem?  (Read 665 times)

Molly

  • Newbie
  • *
  • Posts: 3
    • View Profile
Tile Molester GUI Problem?
« on: May 23, 2018, 11:19:34 pm »
Hello, I wanted to start using Tile Molester instead of YY-CHR for some graphics editing, but I ran into a very odd problem
None of the images in the toolbars, or mouse pointers, are visible! Each of the UI buttons are teeny tiny blank squares, and the mouse just disappears when it's supposed to switch to a program-specific graphic.
Here's a screenshot of the window, showing the problems
Spoiler:
I tried re-downloading, and also downloading a separate version, but it still has the same problem
While this doesn't make the tool impossible to use, it's incredibly difficult when I don't know what (tiny) button does what, and can't see where my mouse is

(Also hope this is in the right section...)

NERV Agent

  • Sr. Member
  • ****
  • Posts: 404
  • EYAH! AAAAAAAAAAAAAAAHHHH!!!
    • View Profile
Re: Tile Molester GUI Problem?
« Reply #1 on: May 24, 2018, 02:05:11 am »
This is odd. It seems that the buttons that should be there have been turned into tiny little squares.

Do you have the latest Java installed? Also, what is your OS?

Where did you download your copy of Tile Molester from? The working one I have is from RHDN.

http://www.romhacking.net/utilities/109/
Pen Pen Toblerone Vomit is waifu of the year.

Molly

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Tile Molester GUI Problem?
« Reply #2 on: May 24, 2018, 08:48:28 am »
This is odd. It seems that the buttons that should be there have been turned into tiny little squares.

Do you have the latest Java installed? Also, what is your OS?

Where did you download your copy of Tile Molester from? The working one I have is from RHDN.

http://www.romhacking.net/utilities/109/
I checked, and I do have the latest version of Java. I am on Windows 10
And, I also have downloaded the program from this site... 3 times. All 3 times it had the same problem when launching
I was thinking that something might have been missing from the download, but then if that was the case, there'd be other people having the same problem

Jorpho

  • Hero Member
  • *****
  • Posts: 3828
  • The cat screams with the voice of a man.
    • View Profile
Re: Tile Molester GUI Problem?
« Reply #3 on: May 24, 2018, 11:25:34 am »
Does Tile Molester Mod work any better?
http://www.romhacking.net/utilities/991/

Also, to be sure, is your Windows language set to en-US, or something else?

If all else fails, you could run it in VMware Player in a Linux or Windows virtual machine, but there's probably a simpler solution.
This depresses me. I feel like a goldfish right now...

Molly

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Tile Molester GUI Problem?
« Reply #4 on: May 24, 2018, 11:37:04 am »
Does Tile Molester Mod work any better?
http://www.romhacking.net/utilities/991/

Also, to be sure, is your Windows language set to en-US, or something else?

If all else fails, you could run it in VMware Player in a Linux or Windows virtual machine, but there's probably a simpler solution.
Tile Molester Mod has the exact same issue. It's one of the three versions I checked

NERV Agent

  • Sr. Member
  • ****
  • Posts: 404
  • EYAH! AAAAAAAAAAAAAAAHHHH!!!
    • View Profile
Re: Tile Molester GUI Problem?
« Reply #5 on: May 25, 2018, 12:01:18 am »
I'm inclined to believe Windows 10 is the issue. If at all possible, try running TM on a machine with Windows XP or Windows 7. If it works on that machine, then it confirms my suspicions.

Is anyone else here using Windows 10 having the same issue with Tile Molester?
Pen Pen Toblerone Vomit is waifu of the year.

Mauron

  • Sr. Member
  • ****
  • Posts: 421
    • View Profile
Re: Tile Molester GUI Problem?
« Reply #6 on: May 25, 2018, 12:59:54 am »
I've run Tile Molester on Windows 10 without issue.
Mauron wuz here.

Jorpho

  • Hero Member
  • *****
  • Posts: 3828
  • The cat screams with the voice of a man.
    • View Profile
Re: Tile Molester GUI Problem?
« Reply #7 on: May 25, 2018, 01:30:09 am »
Does your Tile Molester directory have three sub-folders named "docs", "languages", and "resources"? If not, you may have extracted the archive incorrectly.

Also, how exactly are you running Tile Molester?  Are you just double-clicking tm.jar?
This depresses me. I feel like a goldfish right now...

Psyklax

  • Hero Member
  • *****
  • Posts: 674
    • View Profile
    • Psyklax Translations
Re: Tile Molester GUI Problem?
« Reply #8 on: May 25, 2018, 01:49:45 am »
Just to add to the topic: I'm using Windows 10 and just click TM.JAR and it works perfectly. I'm using the same copy I had on Windows 7 and Windows XP, never changed it.

No idea what could be causing this problem for the OP, though. :(

NERV Agent

  • Sr. Member
  • ****
  • Posts: 404
  • EYAH! AAAAAAAAAAAAAAAHHHH!!!
    • View Profile
Re: Tile Molester GUI Problem?
« Reply #9 on: May 25, 2018, 04:51:52 am »
Hmmm. Okay, maybe OP should try using a batch file to open it.

Put the following in a Notepad file:

Code: [Select]
cd [directory where tm.jar is, NOT tm.jar itself]
tm.jar

And save it as a ".bat" file.

So for my copy, I extracted it right it my C:\ drive, so for me its:

Code: [Select]
cd C:\tilemolester-0.16\tilemolester-0.16
tm.jar
Pen Pen Toblerone Vomit is waifu of the year.

Jorpho

  • Hero Member
  • *****
  • Posts: 3828
  • The cat screams with the voice of a man.
    • View Profile
Re: Tile Molester GUI Problem?
« Reply #10 on: May 25, 2018, 09:58:39 am »
Code: [Select]
cd [directory where tm.jar is, NOT tm.jar itself]
tm.jar
If that doesn't help, using the line
Code: [Select]
java -jar tm.jarmight be a good idea.

It also might be a good idea to check the Java Control Panel (which should be accessible from the Start menu).  Maybe try deleting the Java cache.  (From the General tab, click the Settings button under Temporary Internet Files.)  If you're practically out of hard drive space, that might have something to do with it too.

It occurs to me there might be something weird running in the background that purposefully interferes with the running of Java applications (since they're known to be a bit of a security risk), but I have no idea what that might be.
This depresses me. I feel like a goldfish right now...

q8fft

  • Jr. Member
  • **
  • Posts: 31
    • View Profile
Re: Tile Molester GUI Problem?
« Reply #11 on: June 03, 2018, 08:13:19 pm »
this because you run deterrent file same name, just you need delete file you editor from "resources" folder and run the program again will work.