News: 11 March 2016 - Forum Rules
Current Moderators - DarkSol, KingMike, MathOnNapkins, Azkadellia, Danke

Author Topic: Super Mario Bros. NES problem after Mario or Luigi save Toadstool/Mushrooms  (Read 1344 times)

szemigi

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
Well, I'm using Luigi Game IPS patch by YY, I edited all the castle levels already. That's okay.

BUT: When I touch the axe with Mario or Luigi, after that both of them stop randomly at the princess/mushroom retainers. It means sometimes Mario and Luigi stops at the princess/mushroom retainers, sometimes on the princess/mushroom retainers, etc.

I tried to fix it with moving the scroll stop, but with - especially Luigi - it the problem is the same. I tried it with Mario, which is kinda works, but sometimes he does the same as Luigi, too.


Help me!

Eden.GT

  • Full Member
  • ***
  • Posts: 103
  • Hardcore SMB1 Player and Hacker
    • View Profile
Guidelines for Mario/Luigi to position correctly after touching the axe:
•Where the bridge, rope and axe must be is at an even page number. E.G. 0,2,4, etc.
•Changing the speed of the player can result in either Mario too fast to stop at the default location, and vice versa.
•Defaults: Bridge - Horz. Pos. 1,
          Rope - Horz. Pos. 12,
          Axe - Horz. Pos. 13, 
          Scroll stop [next page] - Horz. Pos. 5.
•Sometimes, depends on the level itself, Mario touching the right edge of the axe can cause position instability and text might not appear.
I'm not sure whether the patches have a side effect on the scroll stop object.
Is the pool clean?

Dr. Floppy

  • Restricted Access
  • Hero Member
  • *
  • Posts: 972
  • Make America GREAT Again!
    • View Profile
    • BaddestHacks.net
What happens when you just leap over the axe?