News: 11 March 2016 - Forum Rules
Current Moderators - DarkSol, KingMike, MathOnNapkins, Azkadellia, Danke

Author Topic: Does this site accept hacks that require a niche outdated emulator to run?  (Read 2377 times)

Special

  • Full Member
  • ***
  • Posts: 228
    • View Profile
Couldn't find the answer to this, but are there requirements to submitting translations/hacks, such that they work on real hardware and or multiple emulators.

Or can hacks be submitted that will require the use of a 3 year old version of FCEUX and nothing else will work to run these hacks?

Mauron

  • Submission Reviewer
  • Hero Member
  • *****
  • Posts: 540
    • View Profile
Re: Does this site accept hacks that require a niche outdated emulator to run?
« Reply #1 on: September 22, 2017, 01:35:30 pm »
This is from the hack submission page, as an example of not acceptable:

Emulator Specific Hacks: Any hacks that are known to only run properly on a single emulator such as ZSNES or Nesticle only hacks.
Mauron wuz here.

Special

  • Full Member
  • ***
  • Posts: 228
    • View Profile
Re: Does this site accept hacks that require a niche outdated emulator to run?
« Reply #2 on: September 22, 2017, 02:31:30 pm »
Hmm, I missed that... ;)

That's what I thought initially, but then there are these hacks that seem to break those rules, because these require an old version of FCEUX.

Ludmeister's Remix
https://www.romhacking.net/hacks/885/
Rise of Ieyasu 2.0 https://www.romhacking.net/hacks/994/
Rise of Lu Bu https://www.romhacking.net/hacks/966/
Yuan Shao's Revenge http://www.romhacking.net/hacks/965/


Psyklax

  • Hero Member
  • *****
  • Posts: 1073
    • View Profile
    • Psyklax Translations
Re: Does this site accept hacks that require a niche outdated emulator to run?
« Reply #3 on: September 22, 2017, 03:19:53 pm »
Hmm, all for the same game... Seems really odd that people would hack a game in a way that requires a deprecated emulator. Seems baffling to me. I don't even understand how that can be. :huh:

KingMike

  • Forum Moderator
  • Hero Member
  • *****
  • Posts: 6927
  • *sigh* A changed avatar. Big deal.
    • View Profile
Re: Does this site accept hacks that require a niche outdated emulator to run?
« Reply #4 on: September 23, 2017, 02:05:28 pm »
Either it was the only ROM they found and they don't know better, or more likely they want to take advantage of unintentional enhancements offered by inaccurate emulation (such as MMC3 with up to 2MB ROM).
(or maybe intentional enhancements? Like N64 texture packs is the best example I can think of, and much less known, an HD SMS emulator)
"My watch says 30 chickens" Google, 2018

Mauron

  • Submission Reviewer
  • Hero Member
  • *****
  • Posts: 540
    • View Profile
Re: Does this site accept hacks that require a niche outdated emulator to run?
« Reply #5 on: September 23, 2017, 02:32:02 pm »
From the hack descriptions, it looks like sonic.penguin added some graphical enhancements that don't work right, and the other hacks are using the same graphical changes.
Mauron wuz here.

Spinner 8

  • Sr. Member
  • ****
  • Posts: 447
  • Pink Pretty Princess
    • View Profile
Re: Does this site accept hacks that require a niche outdated emulator to run?
« Reply #6 on: September 24, 2017, 04:08:14 pm »
Either it was the only ROM they found and they don't know better, or more likely they want to take advantage of unintentional enhancements offered by inaccurate emulation (such as MMC3 with up to 2MB ROM).
(or maybe intentional enhancements? Like N64 texture packs is the best example I can think of, and much less known, an HD SMS emulator)

It's because of the expanded ROM that the DoaE editor uses, which converts the mapper to 245.

From the tiny amount of research I did, it looks like mapper 245 support got bugged in FCEUX at some point, which is why an older version is recommended. But, the hacks should work fine in anything else that supports that mapper (including EverDrive).

Special

  • Full Member
  • ***
  • Posts: 228
    • View Profile
Re: Does this site accept hacks that require a niche outdated emulator to run?
« Reply #7 on: September 24, 2017, 07:46:30 pm »
Other emulators that support mapper 245, do not run these hacks at all, Mesen for example has a very high compatibility https://www.mesen.ca/#Compatibility

I'd be interested in knowing any emulator that can run these...

These hacks probably rely on bugs/inaccuracies in the emulator they were developed with, and as FCEUX became more accurate over time, these hacks are now useless unless played on the same exact outdated emulator.

VicVergil

  • Hero Member
  • *****
  • Posts: 715
    • View Profile
Re: Does this site accept hacks that require a niche outdated emulator to run?
« Reply #8 on: September 25, 2017, 01:27:24 pm »
I'm happy the many ZSNES-dependent translations got to be hosted here a little while longer until someone else years later stumbled on them and fixed them, rather than being immediately removed in the name of emulation accuracy. I could still use them with those deprecated emulators that way as opposed to playing them in Japanese.

Retroactive enforcement of this "rule" ... opens a big can of worms. Might as well go and delete Super Boss Gaiden because it turned out to be too buggy for real Snes CD hardware.
But this is 2017. People don't like that options they don't like to exist, and can't just go their way and ignore it. The option has to be removed. In this case, it's about emulator accuracy. Apple delisting tons of games incompatible with their iOS #255 is suddenly okay, we can purge it off the database and just expect long retired developers to come back and fix this stuff to keep with the new developments.

There's already non-compliant reports and negative reviews for quite a few hacks here just over the ROM information including the ROM name and set and CRC, but not the SHA-256 hash, and that makes scraping this website's database harder for them. I mean if you're willing to try and have a hack taken down because of that detail, you don't care about it in the first place.
« Last Edit: September 25, 2017, 01:33:04 pm by GHANMI »

KingMike

  • Forum Moderator
  • Hero Member
  • *****
  • Posts: 6927
  • *sigh* A changed avatar. Big deal.
    • View Profile
Re: Does this site accept hacks that require a niche outdated emulator to run?
« Reply #9 on: September 25, 2017, 07:22:10 pm »
I heard about that, Flappy Bird will be/is now incompatible (whichever).
While it seems like a game that got far more popular that it probably should've been, it regardless did become a phenomenon and thus of a historical significance.

But it sounds like even the creator of the game didn't like the reception it got.
"My watch says 30 chickens" Google, 2018