News: 11 March 2016 - Forum Rules
Current Moderators - DarkSol, KingMike, MathOnNapkins, Azkadellia, Danke

Author Topic: ROM Hacks: Super Mario World The Lost Adventure Episode 1  (Read 18123 times)

KingMike

  • Forum Moderator
  • Hero Member
  • *****
  • Posts: 6894
  • *sigh* A changed avatar. Big deal.
    • View Profile
Re: ROM Hacks: Super Mario World The Lost Adventure Episode 1
« Reply #20 on: September 14, 2012, 06:08:31 pm »
Quote
the header data is far more specific about the ROM image size, which might help it be loaded faster than it would be if the size had to be recalculated every time?
Without a header:
Code: [Select]
fseek(file,0,SEEK_END);
ROMSize=ftell(file);

Whereas with headers, you need extra lines of code to first check if a header is present, then you need extra to seek to the specific byte(s) with the size, and read it.
"My watch says 30 chickens" Google, 2018

Alcahest

  • Jr. Member
  • **
  • Posts: 62
  • Demon of Elru
    • View Profile
Re: ROM Hacks: Super Mario World The Lost Adventure Episode 1
« Reply #21 on: December 28, 2013, 11:49:00 am »
I can confirm many music issues (missing or choppy as hell) on real hardware, but more troubling, the game crashes all the time, usually as black screens when entering pipes.
A soft reset is then required :S
Otherwise an overall enjoyable hack!

Alcahest

  • Jr. Member
  • **
  • Posts: 62
  • Demon of Elru
    • View Profile
Re: ROM Hacks: Super Mario World The Lost Adventure Episode 1
« Reply #22 on: June 27, 2014, 08:47:08 pm »
I grabbed version 1.1 since my last post, a LOT of stuff was corrected,  no more crashes due to music or otherwise.
And I seriously had a blast !

But now I just reached the final castle "Shadow Dungeon" and it crashes the game:
-when mario dies.
-when entering the Boss / Red door, arrrrg XD

I'm paying on real hardware via SD2SNES.

isaix, if you're still around, is there hope for a fix? I can of course provide my SRAM if needed.

isaix

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: ROM Hacks: Super Mario World The Lost Adventure Episode 1
« Reply #23 on: December 01, 2014, 08:56:51 pm »
I grabbed version 1.1 since my last post, a LOT of stuff was corrected,  no more crashes due to music or otherwise.
And I seriously had a blast !

But now I just reached the final castle "Shadow Dungeon" and it crashes the game:
-when mario dies.
-when entering the Boss / Red door, arrrrg XD

I'm paying on real hardware via SD2SNES.

isaix, if you're still around, is there hope for a fix? I can of course provide my SRAM if needed.

I don't know what could cause the game to crash in the Shadow Dungeon,so I don't think I could fix it unfortunatly