News: 11 March 2016 - Forum Rules

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - NoMadTheorist

Pages: [1]
1
DuckStation is brand new and it is a great one that you can pick up. Yes, it is better than ePSXe version.

Ah, thanks for the suggestion. I'll try that one out soon. :)

2
Hello acediez!

(UPDATE AS OF MAY 15, 2021) I found out that the "bug" that I referred to in here is actually an emulation bug caused by EPSXE 205 running on Windows 10. I concluded this because when I tested the same game file with DuckStation v2.0, the UP button works in the menu. So I guess nothing needs to be fixed.

As a recent Megaman fan who has played X5 for the first time just right now, I want to thank you so much for creating this improvement patch. It really helps in creating a more streamlined and totally unique experience with the game even with its obvious flaws and I especially had a lot of fun experimenting with the revised parts system.

While the game ran flawlessly in all other areas, I did see a major bug or issue that came while I played version 1.6.4, however - by the way I'm using EPSXE 205 with the EPSXE GPU core for this:

The UP button in the D-pad does not work in the weapons selection menu, regardless of which character I pick, yet the UP button responds in all other menu screens and in-game.
  • This means that I cannot use subtanks or weapon tanks, which would ultimately matter in defeating the final boss, yet I was able to climb ladders and hang onto ropes.
  • I tried switching to version 1.5 of this same patch with the same save file, but the bug did not go away.
  • Switching emulation options also did not fix the bug.

It seems to be an actual bug in the patch though its possible that my emulator is at fault too, but since my laptop is pretty weak clock-wise (Intel Core i3-7100-U, max clock rate 2.3 GHz, but has 12 GB RAM) I cannot test it with more demanding emulators such as Mednafen.

Also this video (https://youtu.be/0GhzDLad33Y?t=2634) on a playthrough of this patch with version 1.5 (not stated but implied from its date) clearly shows the UP button working in the weapons menu, yet it doesn't work for me.

I brought this issue since I've read not yet any single reply that mentions this strange bug. It'll be greatly appreciated if a possible fix can be provided in the next version or a suggestion.



Pages: [1]