News: 11 March 2016 - Forum Rules
Current Moderators - DarkSol, KingMike, MathOnNapkins, Azkadellia, Danke

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - redleaves

Pages: [1]
1
You need a custom PSP firmware that'll play unsigned EBOOT's. I have no clue how that works on the PS3 emulating a PSP, but maybe this explanation will help you find a way? (If you do, then please report back for others to know.)
Following your comment, I tried rebundling the ISO with a signed EBOOT.BIN to no success, but among the things I've tried:

1) Fixing the LBA table (somehow something was wrong with EBOOT.BIN's LBA position?).
2) Replacing the patched EBOOT.BIN with the original EBOOT.BIN.
3) Sign EBOOT.BIN with PrxDecryptor.exe in PSP2PS3.
4) Sign EBOOT.BIN with seboot.exe in PSP2PS3.
5) Sign EBOOT.BIN with sign_np.exe.

Solutions 1, 3, 4 and 5 will boot all the same, but won't save.
Solution 2 won't boot at all.

For those interested, this is on a Rebug 2.82 CFW PS3.
I tried all of these with the "PSP Remasters Launcher" and I'll try again with the other available Launcher since some subtle differences  exist between the two.

By the way, a subject came up while researching the issue: it seems that some ASM hacks won't work on the PS3. So just in case, I'm asking: are there any chances that some changes were applied around the syscall initiating the saves?

Thanks for the help

2
Hi,
Tried to play the game on CFW PS3 (mount ISO, then ISO Remaster Launcher) only to find out I couldn't save.

By digging more, I noticed a few things:
- the original version can still save properly.
- if I save in the original version, then try to load with the patched iso, I can see the save, but I get a failure when loading it.
- the original iso contains different files for EBOOT.BIN and BOOT.BIN, the patched iso doesn't (the MD5 checksums match).
- tried to convert to PKG format through aldo's PSP2PS3 tools, but I got errors about the EBOOT.BIN not being signed (PPSSPP reacts the same, as it won't dump the decrypted eboot on the patched version), and not being signable because it's "an ELF file".

So...could that be a bug introduced by modifying the original Eboot file?

Thanks for your help

Pages: [1]