Romhacking => Newcomer's Board => Topic started by: mantidactyle on March 04, 2018, 05:01:56 am

Title: Cannot log on DataCrystal
Post by: mantidactyle on March 04, 2018, 05:01:56 am

I was not sure where to post this since there is no Site section on the forum.

Issue is in the thread name. I arrive on the login page, I enter my username and password, then I'm sent back to the Main Page, still not logged in. I tried emptying the cache / local, to no avail.

Help would be appreciated :)
Title: Re: Cannot log on DataCrystal
Post by: Mauron on March 04, 2018, 05:21:46 am
Others are having the same issue. (
Title: Re: Cannot log on DataCrystal
Post by: mantidactyle on March 29, 2018, 04:28:05 pm
Toying with my cookies resolved the problem, can't say it's a user friendly solution though.
Title: Re: Cannot log on DataCrystal
Post by: NaOH on April 08, 2018, 03:21:36 pm
mantidactyle, are you able to elaborate on your solution? A non-user-friendly solution is better than no solution!
Title: Re: Cannot log on DataCrystal
Post by: mantidactyle on August 12, 2018, 05:44:14 pm
I just got the issue once again. This time I simply removed the values in my cookies, emptied local storage / cache, and it worked
Title: Re: Cannot log on DataCrystal
Post by: yetisyny on August 14, 2018, 04:33:12 pm
I have the same problem, I have never been able to login to the DataCrystal wiki here. Sometimes I get the error message “There seems to be a problem with your login session; this action has been canceled as a precaution against session hijacking. Go back to the previous page, reload that page and then try again.”

Other times I get the error message “Incorrect username or password entered. Please try again.” I get this second error message if I delete cookies for the DataCrystal wiki like people here suggest.

In both cases, trying again gives me the same error message again.

My username is not a problem, is it? It is just 8 alphanumeric letters. It is possible that my password for romhacking dot net might not work on the DataCrystal wiki since maybe the MediaWiki software that the wiki runs on has different password requirements than the main site. I might be using characters in my password that are not allowed in MediaWiki passwords but are allowed in romhacking dot net passwords. Or maybe the password lengths allowed are different?

Obviously something is wrong. It might even be possible that I don’t have an account on the wiki despite having one on romhacking dot net, since I have not had a romhacking dot net account for very long, just about a month or so. Do I have to wait longer before I am able to have a wiki account or something? According to the DataCrystal wiki I ought to have an account there with the same login as my romhacking dot net account if I have a romhacking dot net account.

Anyway I have valuable information I can add to the wiki. Not very much, just a little currently. But I have looked at and tested Pro Action Replay codes for at least one SNES game and found things in the memory of the game that are not in the RAM map of that game on the wiki. So I could improve the RAM map by adding that data. And a bunch of games do not have RAM maps at all, I could at least start them by using a little bit of data from verified Pro Action Replay codes I have tested, this would be better than having no information at all about their RAM layout.

But to do that I need to be able to edit the wiki here and right now I can’t login to it, I get those 2 different errors depending on if I clean up my cookies or not. I can see from the wiki history that some people are able to edit it successfully but it is not terribly active, I guess since a lot of us are having trouble. Really a shame. Apparently for mantidactyle, cleaning up the cookies was able to solve it for them, but for me, it doesn’t accept my username and password even after cleaning up my cookies, local storage, cache and so on, all that does is change which error message I get. I still get an error message no matter what.
Title: Re: Cannot log on DataCrystal
Post by: Zynk on August 15, 2018, 01:04:40 am
I can confirm that I can login to DataCrystal by typing in your LOGIN NAME (not exactly your FORUM NAME) and then your password used here.
Title: Re: Cannot log on DataCrystal
Post by: Raeven0 on August 21, 2018, 02:08:14 am
I can't log in, either. I'm seeing the same behavior that yetisyny sees. Clearing cookies did not fix the problem. Anyone have any other ideas?