Romhacking => Personal Projects => Topic started by: katage on March 31, 2014, 09:46:52 pm

Title: Link's Awakening hack: New Awakening
Post by: katage on March 31, 2014, 09:46:52 pm
Since a lot of people have downloaded my hack New Awakening in the past month, I decided it might be wise to start up a thread to see if anyone had any questions or comments on the mod. I prefer to operate with lots of feedback and so far I've only gotten a couple of complaints, and it didn't take long to address them, leaving me on my own.

I've been updating the hack more or less regularly so far, so there are noticeable differences between different versions of the hack, but I've set up a walkthrough on Youtube that shows how various puzzles can be solved and where the player needs to go at this or that point in the game. The walkthrough isn't perfect, as it has some unnecessary backtracking when I stopped paying attention to what I was doing and played on autopilot, but it shows how everything can be done, and also shows how to get the extra keys available in the dungeons (I added in excess keys and key-saving tricks to reduce the chance the player might get stuck). I'll update it when the newest version requires different puzzles. Here is the link: (

Let me know what you think.
Title: Re: Link's Awakening hack: New Awakening
Post by: njosro on June 21, 2014, 09:55:00 pm
Hi there, I know this topic is a few months old but I thought I'd post anyway. I just downloaded the latest version of your hack two days ago and now I'm on level 6 Catfish's Maw. The hack so far overall is a lot of fun :) I like all the new dungeon layouts and overworld secrets. Oh and the new dialogues :) I do have some issues with it though...

In level 1 I got stuck in the room before the feather because I made the treasure chest appear before I got the feather which made it impossible to ever actually obtain it.

In the color dungeon there are absolutely no keys to be found (at least I couldn't find any) so I couldn't do much of it.

In level 4 (turtle rock), that sideview tunnel screen leading to the miniboss room really ticked me off. You have to jump in MID-AIR with the pegasus boots in order to get across... Seriously? I had to watch your video in order to figure that out. I didn't like that. Even in level 5 when you have to do it again except with the giant blob bouncing around it was not fun... just annoying.

In level 5, that idea of falling into the other dungeon is pretty cool! But falling through multiple screens is kind of weird. It looks like it's not supposed to happen. The only reason I knew I was doing ok was because of the owl.

In level 6, that thing where you have to fall down through multiple screens is kind of lame.

Also in level 6, it's really confusing. Since I got the first item there is to get, I though I could go. But after watching your video it seems I missed the bracelet upgrade AND the hookshot (thankfully I found the other hidden one in some cave beforehand.) Three items all hidden in my least favourite dungeon :(

Oh and idk if it's just my emulator (lameboy for the ds), but whenever i did a normal save (e.g. save & continue from gameover), the game would subtract one piece of heart that i had!! so i use savestates now and always choose continue without saving.
Title: Re: Link's Awakening hack: New Awakening
Post by: katage on June 23, 2014, 05:44:53 am
I have been in China for a while and unable to access the Internet for quite some time. My apologies for the late reply. This is a long post.

Thank you for the feedback. I've been wondering how my hack was seen, and I see your points. I will go over the color dungeon and make sure it works, but I think one of the issues, which might explain your not finding any keys, is that there is a moving block puzzle and the sprite bank cannot be made quite right, the result being that the moving block isn't immediately recognizable. That puzzle releases a key, so you might have missed that. I think I will replace it with a different puzzle or something. I can see why the sprite might be a problem.

I have fixed the Tail Cave chest problem already, but the new version is not yet posted. I'll make more revisions before I post a new version.

I thought the midair jump in Turtle Rock was very interesting, but I think I will take it out. It's not worth it if it causes trouble or frustration for players.

I will need to think about changing the transition from Angler's Tunnel to Catfish's Maw. I based the idea on a shortcut I found with screen warping on the original game, in which you can fall from one to the other. I might preserve the drop, but find a more graceful way to do it. Maybe I'll replace the drop with a normal stairway. Or maybe I'll just reorder the dungeons so they don't connect at all.

I'll get rid of the bouncing blob in the side scrolling area you mentioned. Maybe I'll replace the sprite with a Goomba, just so the room isn't empty.

I thought falling down the multiple screens in level 6 was kind of cool since you get to see screwy tiles (it has to do with a screen being side-scrolling or top-down). I thought it would be interesting for the player to go through a weird tunnel, not knowing what's going or why, only to end up right where he or she needed to go. But I'll take it out anyway. I'll reorient the puzzle. Besides, people might think it was a bug and not like it.

As for getting stuck in walls in level 6, I think I removed the last of those already. But the revised versions with the fixes constitute the minority of the downloads of my hack, so I'm not sure if you're playing a fixed version. If you've downloaded it recently--or even if you haven't--please let me know exactly where you got stuck. I know there was one place where you could hop off a ledge and get stuck, so I replaced that tile with a bombable wall-type ledge (which you can't jump off of), but I'm sure I haven't posted that version yet.

Least favorite dungeon, Catfish's Maw: I've had lots of trouble trying to orient that level so it works okay. Thing is, I can't change the rooms where you fight the Master Skeleton, nor can I have the player enter them from a new direction, so I've had to build around a certain model I can't change, while still trying to make the structure new and unfamiliar (having that fourth boss room so close to the entrance was a pain even in the original, but I can't move it away). I might reorganize the whole dungeon, since I can imagine how it would get confusing. In trying to minimize backtracking, I may have made the structure too counterintuitive to navigate. And just in case that doesn't work, maybe I'll put the second bracelet in another dungeon, someplace where it's bound to be found, and add an elephant so the player doesn't finish the dungeon without it. And maybe I'll bring the Hookshot to Angler's Tunnel, and fix Catfish's Maw so you don't need it anymore. That way the Flippers won't be interpreted as Catfish's Maw's only treasure.

Let me know if there are any other things you didn't like. And tell me if there's anything I need to change about the text. And let me know if anyone is disappointed by the absence of Marin. I would need to more or less completely redesign the hack to keep her in the game without introducing a game-breaking bug, but I know Marin is fun.

Also, I'm curious about your reaction to some of the puzzles I thought might be too rough in the hack. For those who have not finished the game, the rest of this post contains spoilers.

Prologue: Is there enough powder to get to Tail Cave without too much hassle?

Tail Cave, Bottle Grotto, Key Cavern: Any concerns about not fighting the bosses to get the Instruments? You do lose a Heart Piece by forgoing them.

Key Cavern: Too many enemies? The player admittedly has to fight with Powder and Bombs, and I don't know how other people handle this. Having created and tested the mod, I can get through the dungeons without getting hurt more than once or twice, but the player has not fought these enemies ten times over, and I don't know if it's too dangerous or crowded in there for everybody else.

Turtle Rock: Any trouble getting through that room before the Wand? I've made it easier, but I thought I would ask.

Catfish's Maw: Trouble with the Cue Ball enemy, spike trap, and fireball room? There used to be 2 Cue Balls, but I might not have cut down the difficulty enough.
Trouble with the boss key chest?
Trouble with the way to the Flippers?

Eagle's Tower: I've made the side-scrolling section in Eagle's Tower a little easier, but did it cause problems in its un-nerfed form?
Trouble with the southwest corner room on the second floor? It requires a weird Hookshot trick in the most recent version, assuming I've posted that version.
Trouble around the northwestern rooms of the first floor?
Trouble with the crystal switch puzzle in the room two screens north of the entrance? It's optional if you do the Cue Ball room, but I thought I'd ask.
Trouble with that boss room with two Cue Balls and the laser? It's optional if you do the crystal switch room above.

Face Shrine: Trouble with the room three spaces south of the northwesternmost room? I'm not sure I've posted this version, but it's very wacky.
Did anyone find extra keys in the Face Shrine? I tweaked the version to remove an excess key or two, but I'm not sure if anybody else came across the issue.
What do you think of the room with the four moving blocks? I spent a lot of time designing the room, and thought it would be extremely difficult to solve it. It's supposed to be hard, but I wanted to know your thoughts.
Any trouble with the dungeon in general? A lot of the sprites, chests, and tiles in there are red herrings, so sometimes they require some outside the box thinking.
Title: Re: Link's Awakening hack: New Awakening
Post by: njosro on June 25, 2014, 11:42:33 am
I'll try and go point by point.

I'm always happy to give feedback if it'll help. Overall I like the hack! It just has those quirks and glitches that need to be fixed. For the colour dungeon I think I know which room you're talking about... I'll try it again. You don't necessarily have to change the puzzle if you give the player the compass beforehand so that they'll know there's supposed to be something in that room.

Turtle rock mid air jumping is clever, but when you were talking about this hack you said that the challenges wouldn't require perfect reflexes, foresight, or guesswork. This challenge kind of breaks that promise. If you don't have the foresight of how the mechanics of Link jumping works, then you have to guess the solution, which requires (almost) perfect reflexes to hit the jump button at the right time.

I like how the dungeons linked together, but maybe it can be done via staircases? Like a secret underground passage that takes you from one to the other. A high cliff in the passage could ensure one-way travel.

For level 6 falling down multiple screens... you're right. It seems like a bug, like something a speedrunner would exploit.

When I said I was getting stuck in walls in level 6... I meant Face Shrine (sorry for the confusion) and it's in the room 1 west, 1 north from the entrance. I used the hookshot on the treasure chest thinking it might somehow open it but I just got stuck jumping between the two walls.

Have you ever played Catfish's Maw in Nightmare's Illusion by jigglysaint? In that one, the locations of the rooms (including the skeletons!) are all different. I think the trick is to swap out the map id, S.O.G., floor tile, animation, and wall tile info with that of an unused room. It's like a copy/paste job with the numbers. I don't know how the skeleton rooms will be affected but it's worth a try. At any rate, rearranging the other rooms around the skeleton rooms is a good idea.

Overall, the only things I truly didn't like were things that looked glitchy but are actually meant to be there. I think a good rule of thumb is if it looks glitchy or out of place, don't include it.

OH and one other thing I just remembered: I went exploring and
I climbed the secret vine beside bottle grotto. I went west in the mountains and jumped down to the area north of the telephone booth and Mr. Write's house. I went into some caves to see what I could find. Then when I went back outside I didn't have the feather yet so I was stuck. I actually saved myself by somehow walking through the set of pits at just the right angle!

Keep the text! I love the cute and funny interjections. "Don't you feel all warm and fuzzy inside?", "We're rupees! We love you, Nick!" haha it's great. But you should include how many rupees the player gets: "We're rupees! We love you, Nick! All 100 of us!" (or something like that)

It's kind of better that Marin's gone. Sure, some people think it's fun. But if she causes problems just leave her out.

Prologue: yes there is enough powder thanks to the upgrade available right near the witch's hut. As the number ticked down each time I used the powder it just reminded me to use it wisely!

Tail Cave, Bottle Grotto, Key Cavern: No real concerns about not fighting the bosses. I just thought it was a little strange, but it was ok. Having fewer heart containers made it a little harder but I found lots of heart pieces so I was ok. Except for some reason when I chose the save option, the game ALWAYS subtracted one piece of heart that I had! So if I had 2/4 it would go down to 1/4. If I had 0/4 I would lose a heart container all together. But I think that's out of your control. I used savestates to get around that.

The Key Cavern was okay for me but that's because
I found the level 0 sword in the cave next to Kanalet Castle.
Otherwise it would have been really really hard. You should consider removing some enemies.

Turtle Rock: The room before the wand is the miniboss, right? It was fine. No complaints there! But I've played this game a lot so I know how to fight him even with spikes around the room. I think having him in an empty room might be better just in case.

Angler's Tunnel: I liked that room where you need to use the hookshot to quickly pass through the closing blocks! I didn't like the room below it where the ledge heights were inconsistent and not nice to look at.
I liked the room where you have to do what the owl statue says... with the jars and the water. That was cool.
One thing I thought was weird was when you had to use the hookshot to go across to a block but then there are spikes so you're forced to get hurt. It's in the room 3 north, 1 west from the entrance.

Catfish's Maw: By cue ball I think you mean dodongo snake. Yeah it was tough. Either the fireball or laser should go away. I managed, but, again, I've played the game a lot.
The boss key chest was okay I think... I don't really remember where I got it :$
I think the way to the flippers was fine as well. I don't remember any moments of frustration.

Eagle's Tower: The side scrolling section made me mad. The ground acted like water and the graphics were all messed up! I just walked on the spikes (using up the medicine in the process) to get across.
Southwest corner on second floor: I hookshot across to the block and just got hurt on the spikes. Then I used the hookshot to expand the bridge. If a weird trick is required then I don't think I did it the way it was meant to be done. (I don't think a weird trick should be required in the first place)
Everything else: No troubles. Actually this dungeon was super easy! I was a little bit surprised. I don't remember exactly what I did but those pillars came down really quickly...

Face Shrine: I only made it up to the room 3 east, 4 north of the entrance. I don't know what to do. I'll give it another try today. But I really REALLY don't like the garbage tiles scattered everywhere. It makes me scared to do anything because I keep thinking I'll get stuck in a brick somehow. The red herrings are a neat distraction but I don't think you should resort to confusing cliffs and ledges.
Once I actually get to the rooms you're talking about I'll tell you what I think :)

Keep at it!
Title: Re: Link\'s Awakening hack: New Awakening
Post by: katage on June 26, 2014, 07:34:56 am
I have revised the hack and I believe successfully addressed most of your comments. Those I have not addressed, I explain below. A complete list, assuming I'm not forgetting anything:

Moved the compass in the color dungeon closer to the entrance.
Turtle Rock no longer requires midair jumping.
Linked Angler's Tunnel and Catfish's Maw via staircases. I could not tweak the falling stuff to make it look better.
Face Shrine no longer drops the player multiple screens.
Face Shrine now lacks the Hookshot to endless wall jumping trap.
Added a hole in the overworld on map 11. You can no longer get trapped in the way you described; you need the feather to get there now.
Some of Key Cavern's enemies have been replaced with less vicious monsters.
Eagle's Tower's side scrolling section no longer looks wacky and uses weird tiles. It is also much less horribly murderous.
Face Shrine no longer has weird garbage tile ledge thingies. It has its tricks and turns, but the ledges are coordinated to look normal and the floors have been cleaned up.

Stuff I have not addressed:

The rupee chest messages still don't say how many rupees the player gets. There is not enough room in the text and it would take much rearranging to add room. You can really mess up the text if you exceed the vanilla text range and don't adjust all the surrounding text ranges to suit it.
I don't know how to fix the heart piece loss. I've noticed I've lost a heart piece, if not a full heart, so it's not just the emulator. I am not sure what is causing it. I will simply include a warning in the readme.
The Cue Ball enemy is the goofy miniboss that throws the ball at you. There has always been one in Catfish's Maw in NA, with a fireball thing and a spike trap. I've removed the fireball thing and some spikes if there were any before. Catfish's Maw no longer has a Dodongo Snake at all. I replaced that screen with a puzzle type thing.
I have not changed the room in Angler's Tunnel with the hookshot place you mentioned. You don't really need to hop on those spikes.
You don't need to use the hookshot at all. You can push the square block onto the spikes and bounce off of it with the boots and feather to reach the tile to the right, or, you can hop into the water with the flippers and swim across the gap, if you stick to the northern edge of that tile. You actually swim over the hole due to some sort of engine error, which actually lets you get over a gap without the feather.

Finally, I have tweaked the hookshot-related room in Eagle's Tower.
You don't need to hookshot across that gap and hookshot backward to extend the bridge. You can hookshot the bridge when standing on it and the bridge will extend backward, behind you, instead. The owl now gives a less vague hint about it. Another room in the Face Shrine uses the same trick, though I have simplified that room as well.

I have not posted the new version yet, as I do not have time to test it. For one thing, we've got a Chinese test tomorrow. For another, my bedtime is at 10pm now, and that's less than three hours away over here. I will make a post here when the new version is up and running.

Zaoshanghao, meiguo.

June 27, 2014, 04:35:36 am - (Auto Merged - Double Posts are not allowed before 7 days.)
I have tested the new version and fixed a mistake I made during the revising process, but there is a problem with Dropbox. If it is anything like the other Internet problems I have had in China, it will take a while to resolve.
Title: Re: Link's Awakening hack: New Awakening
Post by: njosro on June 27, 2014, 05:36:11 pm
Dropbox was re-blocked there on June 18th. I know it's none of my business, but I'm curious: whatcha doing in China?

I played all of Face Shrine! And It was pretty cool. It felt a lot like level 9 from the original legend of zelda: full of danger, wrong moves lead you into little traps, and secrets are everywhere. There is one thing though... I didn't get the nightmare key on the first run through, so when I reached the room before the nightmare, I couldn't get in, and I couldn't get out either. I had to use the ocarina to warp to the entrance.

Oh and I did the room with the 4 moving blocks. It was very interesting! I liked it. I had to stare at the screen for a couple of seconds to figure it out. I think it's a good challenge.
Title: Re: Link\'s Awakening hack: New Awakening
Post by: katage on June 28, 2014, 10:09:42 am
I'm studying Chinese here. It's a nine-week intensive language program to cram one year of Chinese study into one summer. I've not had much time for dealing with my hack, but it's the weekend now. I didn't know dropbox was ever blocked in China. I might not be able to post the updated hack at all, not until I get home (that's still 8 weeks away).

The nightmare key in the face shrine is in the farthest northwest room. I put it there, without any puzzles guarding it, to make sure people would get it, but since that got overlooked, I have moved the chest to the room right before Facade. Now it is no longer possible to get trapped.

I'm surprised the moving block puzzle took so little time to figure out. I spent maybe 15 to 20 minutes figuring out how to rig the puzzle so there was only one way to complete it. It went through several versions before I got it to work the way I wanted.

One more thing before I go to bed. I have fixed up the game so that Marin can join the player along the way. I added back in the sprites for Marin and the walrus, then, for the sake of completeness, put Richard back in and made him necessary to reach the Slime Key. I tweaked a few puzzles so Bottle Grotto could come before Key Cavern, and removed all chests with potions in them from the first four dungeons. Getting a potion too early is what causes the game to crash when you meet Marin at the beach; with those potions gone, there is no problem. I played through the game and made sure getting the potion from Crazy Tracy (now at the castle, with the shopkeeper back in town) did not cause the crash.

I also added a shortcut so the player can keep Marin the whole game. Maybe if I rebalance some things and tweak the owl dialogues so they fit the new order, then New Awakening will be truly complete.

June 29, 2014, 08:11:43 am - (Auto Merged - Double Posts are not allowed before 7 days.)
I just fixed the owl dialogues and rebuilt Key Cavern to rebalance the game. New Awakening seems to be reaching its final stage.
Title: Re: Link\'s Awakening hack: New Awakening
Post by: katage on July 11, 2014, 03:11:08 am
With njosro's help, I just posted the new version of the hack. I have reconstructed Key Cavern and Catfish's Maw and added enough Heart Pieces to compensate for the Heart Piece loss bug (there's also an in-game explanation for the phenomenon). There are about 10 extra Heart Pieces spread throughout the dungeons, though a small number (three, I think) have been removed from the rest of the island. Finally, I reintroduced Marin, the walrus, and Richard into the game, without recreating the Marin crash bug. This means the player can't get the potion until after Bottle Grotto, as in the original game, though I have tweaked the difficulty to account for the loss of the potion in the early game.

Now, the only content removed by New Awakening is a few messages from Old Man Ulrira and possibly the ghost. I have changed some of Ulrira's dialogue, and the text of one owl statue, to give the player the same hints they would normally receive (the new sequence would otherwise screw them up).

July 15, 2014, 07:15:53 am - (Auto Merged - Double Posts are not allowed before 7 days.)
I made a mistake in adding the new Pieces of Heart to the dungeons. In Catfish's Maw and Eagle's Tower, the player can lose access to a key by picking up the Piece of Heart too early. I cannot post a fixed version from China, but I can explain how to avoid the bug.

There is a room in Catfish's Maw with a chest and a Piece of Heart. If you open the chest, the Piece of Heart will vanish. Or, if you pick up the Piece of Heart and leave the room, then the Nightmare Key will vanish from the chest. So they are almost mutually exclusive. So, either open the chest first, or make sure you do not have to leave the room between picking up the Piece of Heart and opening the chest.

There is another room in Eagle's Tower with a Piece of Heart and a droppable key, on the second floor. Picking up the Piece of Heart will prevent the key from dropping. Even without that key, you can still complete the dungeon if you use Manbo's Mambo, the second Ocarina song available just west of the entrance to Angler's Tunnel. However, you will need to solve one more puzzle than would normally be necessary to complete the dungeon.
Title: Re: Link's Awakening hack: New Awakening
Post by: katage on August 25, 2014, 02:49:29 am
I have just posted the newest version of the hack. The bugs I mentioned above have been corrected, along with some other more obscure errors I spotted since then. Aside from fixes and minor tweaks, I have added in some new types of puzzles and prevented a fair number of graphical oddities from occurring.
Title: Re: Link's Awakening hack: New Awakening
Post by: katage on December 10, 2014, 02:11:08 pm
There will likely not be any more updates on this project. Apparently hacks created using LALE experience a very slow but inevitable process of decay. Distracting coloration errors have cropped up repeatedly as I have been revising the hack, errors which I can fix but cannot stop. Unless I rebuild the project from scratch, the hack will likely become gradually more unstable until it can no longer display correctly. This is probably the final stage of New Awakening, as further revisions are more likely to damage the hack than improve it.
Title: Re: Link's Awakening hack: New Awakening
Post by: katage on December 18, 2014, 08:21:03 pm
Tetrahedrus has found a possible alternative explanation for the coloration errors I have found in New Awakening, as well as a fix, and because of this, I will likely be able to post a new, updated version that does not suffer distracting palette errors. It's also possible LALE does not have a decay problem at all, and the problem lies elsewhere. Either way, LALE is fantastic and virtually bug-free; Fatories' work is stellar (it's worth repeating).

Anyway, New Awakening may continue to progress.
Title: Re: Link's Awakening hack: New Awakening
Post by: Tetrahedrus on December 18, 2014, 08:44:28 pm
Crisis averted. Hopefully. I am just happy that New Awakening can continue to receive updates when needed and that I likely won't run into any horrible problems as I continue with my hack (yes that's still going).

LALE is amazing. Too bad it's dead.
Title: Re: Link's Awakening hack: New Awakening
Post by: katage on February 15, 2015, 01:27:08 pm
New Awakening's palette error has been corrected! And it has received various new revisions and improvements as well. Version 4.1 is now posted and ready.
Title: Re: Link's Awakening hack: New Awakening
Post by: Systematician on July 09, 2015, 04:03:59 pm
First, I must thank you, katage, for this fun and creative hack of one of my favourite Zelda games.

Since your YouTube walkthrough seems to be unavailable (at least to me), I will ask about one point where I am currently stuck: After having collected the five leaves, I want to speak to Richard. However, he demands I part with Bow-Wow first. Is there a way to do this?

Edit: The real problem might be that I cannot end the walk with Bow-Wow as long as I haven't finished a certain part of Bottle Grotto. I have defeated the boss of that level, but I have not been to the room to the right in the middle of the dungeon (see the map). When in the room to the left of that room, my path is blocked, unless I could bomb the switch while standing on the path being blocked after hitting the switch. Only with the arrow I can reach it, but that doesn't leave me enough time.

Another source of the problem might be that I might have been supposed to find the sword in Bottle Grotto, not in a cave reached from the south-east of the grave yard (I have seen somewhere else on the web that I am supposed to find it in Bottle Grotto, but this might be different in the version I am using (the newest)). After defating the boss of Bottle Grotto, I don't receive an instrument or anything, I can just warp back to the entrance of the dungeon. I don't know if this is a glitch due to me already having got the sword, but if so: How can I cut my way through to the stairs leading to the room before the dungeon boss without a sword?
Title: Re: Link's Awakening hack: New Awakening
Post by: katage on July 11, 2015, 12:52:38 pm
The email account linked to that Youtube video has been disabled. I'll have to start up a new one and re-post the walkthrough.

First, the sword. You ARE supposed to get the sword in Bottle Grotto, and you do need the sword to reach the boss, but you don't need to kill the boss with it. The boss is optional; you get the Instrument in the room near the sword of Bottle Grotto. The reward for the dungeon itself is the Instrument, Bracelet, and Sword; the reward for the boss is simply the heart piece. That's why the boss warps you back to the start of the dungeon, rather than outside--only the Instrument warps you outside the dungeon. The boss is only there for the heart piece.

As for the other sword you got, that is in fact supposed to be there. It's one of the many little secrets of New Awakening that I included for inquisitive players or would-be speedrunners. It's a level 0 sword and weaker than the normal one, and you have to use spin attacks to hurt most anything. I think I'll remove it to prevent any confusion--it seems too easy to find, for an item that opens up the possibility of minor skips.

To solve your problem: you don't need the Bow to get past that area in Bottle Grotto (the room that's three screens north and one screen east of the entrance, with the single bat, crystal switch, and floating heart). In fact, you don't need the Bow at all until the last dungeon, the Face Shrine. To flick that crystal switch at the right time, and therefore reach the rest of Bottle Grotto, just throw a bomb over the wall. That'll give you more than enough time to reach the northeast corner of the map. When it detonates, the crystal switch will activate, the northeasternmost block will lower, and you can move on to the next room. You need a bomb, not an arrow.

So you know, you'll have to return to that room again, this time from the south end, and throw another bomb over the raised blocks and wait for it to detonate. This will lower a different set of raised blocks, and open the next staircase in the room to the right.

I will create a new account on Youtube and post a walkthrough of the most recent version of New Awakening as soon as I can. I'll also post a slightly updated version of the hack, with the level 0 sword removed. It was intended for explorers and speedrunners, but apparently is too easy to find. I'll replace it with something else.
Title: Re: Link\'s Awakening hack: New Awakening
Post by: Systematician on July 11, 2015, 04:23:27 pm
Ah, of course! I simply forgot that I could pick up the bomb again after having placed it.

Thank you very much.

July 11, 2015, 05:30:31 pm - (Auto Merged - Double Posts are not allowed before 7 days.)
You might want to do something about another issue in the new version, although it is possible that it is (again) not a glitch: After getting the Pegasus boots in dungeon three, you can reach dungeon eight through a cave. With the boots, you jump over a large cleft. However, I did not manage to get back to the entrance in that cave with the boots, and it might well be impossible, as there is less room for building up speed on the way back. There also seems to be no other way back, and I didn't get very far in dungeon eight itself.

Fortunately, I had saved my progress before I tried this.

Edit: Another possible glitch of the same kind: You can also reach dungeon six and five after getting the Pegasus boots, but at one point in those dungeons, I did not get further (and at one point actually unable to get back, again due to the boots letting me forwards but not backwards). I was not able to get back from the dungeons either, as I cannot swim yet.

Another more serious glitch - as it is difficult to know if it prevents me even from finishing the dungeons in order - is the following: After trading the honey for the pineapple in the Animal Village, I am told that Marin will be able to awaken the sleeping animal close to the village. She is now by the beach, but after our conversation, I get the error message "Unknown opcode e4 at eff47" in my emulator, VisualBoyAdvance, and the emulation crashes.
Title: Re: Link's Awakening hack: New Awakening
Post by: katage on July 12, 2015, 11:17:02 am
Good news! The dash jump problem you're having is not in fact a glitch. You can actually do the dash jump on a single tile (or even a single pixel!) You don't need lots of room to start the dash. It's quite possible to get across that gap both ways. You just have to press the Feather button a little sooner. To prevent any confusion, however, I'll change every screen with a one-tile dash jump so you get an extra tile to jump.

There is a place in Angler's Tunnel where you can get across a screen without being able to cross back over. You can save and quit to return to the start of the dungeon (any dungeon, actually), but since this might not be common knowledge, I'll change that screen as well, to make it possible to cross it without saving and quitting, or completing the dungeon.

You do in fact need the Flippers to escape Catfish's Maw and Angler's Tunnel, but not any other dungeon (there's a shortcut to the Face Shrine near the tree where you get the honeycomb). I can't provide a dry exit to Catfish's Maw--there's not enough tiles available to make it work--but I'll change the escape from Angler's Tunnel so it doesn't require the Flippers, and you can escape Catfish's Maw by returning to Angler's Tunnel via the normal stairway (the two dungeons are connected in New Awakening).

The Marin glitch is caused by getting the Potion too early. I thought I had prevented the player from reaching Crazy Tracy before completing Bottle Grotto. I'll add a couple rocks to prevent the player from getting the Potion before Marin. But in case you don't have a save from before you got the Potion, here's a shortcut to the desert that doesn't require Marin's help:

Go north from the Animal Village and walk around to the Face Shrine area. In the small maze leading to the southern shrine, you can find a stairway at the south end of a screen. Go down the stairway and you'll drop down to the desert. You can get the Angler's Key from the Lanmola as normal, and escape the desert by dropping off a ledge in the southwest of the desert. You'll fall right in front of the walrus, and then you're free to go.

If you haven't learned the Ballad of the Wind Fish, however, I'm afraid you might need to cheat it in--I don't know if Marin will leave the beach and end up back at Mabe Village, or go to the Animal Village. If she does, you can learn it as normal later on. If she does not, you can use the following Gameshark code: 010749DB. That should add all of the songs to your Ocarina.

Let me know if you feel stuck again.
Title: Re: Link's Awakening hack: New Awakening
Post by: Systematician on July 12, 2015, 02:50:12 pm
Thank you for your reply.

I got the cheat code to work. However, it seems the walrus doesn't wake up just by my singing the Ballad of the Wind Fish and that Marina is still needed ...
Title: Re: Link's Awakening hack: New Awakening
Post by: katage on July 13, 2015, 04:01:14 pm
You don't need the Ocarina to move the walrus. Marin does that for you, but since you can't get a hold of Marin, use the shortcut from the Face Shrine area to enter the desert. So you don't need Marin at all--you've got the song from the code, and you can get the Angler Key using the shortcut to the desert. The walrus will remain asleep in your game, and Marin will remain at the beach, but you'll be able to complete the rest of the game as normal.

I mentioned the cheat code because you still need to know the Ballad of the Wind Fish--not for the walrus, but to open the Wind Fish's Egg. I just wanted to make sure you wouldn't get stuck later on, if you hadn't already learned the 1st song.
Title: Re: Link's Awakening hack: New Awakening
Post by: Systematician on July 14, 2015, 05:07:44 pm
Thank you for that clarification. I should have mentioned that at the time of writing, I still hadn't found the way to Turtle Rock. There, I am stuck in the room with three chests side by side. It seems that this is the room where I can most probably make progress at this point.

One of the few other possible candidates for progress are in the two side-scrolling "cellars" with ice-blocks. In one of those, I cannot get back or further (at least not without using midair jumping or anything similar, which should not be required in the newest version) or die, so this might be a glitch. In the other side-scrolling room with ice blocks, I can get back but I think not further, unless there is a jumping technique I can use. (I haven't really mastered the use of the Pegasus boots combined with the Rock's feather at any point.)
Title: Re: Link's Awakening hack: New Awakening
Post by: katage on July 16, 2015, 01:55:56 am
A midair jump in Turtle Rock is no longer required (a previous version of the hack required it). Now, you can use a wall jump or wall bounce instead like in Key Cavern. Both of the Turtle Rock ice rooms with tricky jumps can be done by bouncing off of the wall, as well as hopping in midair.

There is one screen among the ice rooms where you can't go both ways without the Wand. But you won't get stuck if you cross over, since it deposits you someplace where you can make your way back to the start of the dungeon.

I'm not sure which part of the triple chest room is causing problems. There are two sticky block situations and a bombable wall--you'll have to deal with all three if you want to get the treasure and also escape.
Title: Re: Link's Awakening hack: New Awakening
Post by: Systematician on July 16, 2015, 01:45:39 pm
Thank you. Finally, I have mastered the wall jump/bounce well enough to finish Turtle Rock (my finishing the three chest room of course depended on the wall bounce).

I am currently in level 5 and 6, and I manage fine on my own, appart from one point where I probably not find the principal way to make progress (i.e. without being damaged), but the likelihood of this being due to a glitch is very low.

What I guess is a glitch, however, is the apparent inability to escape from the water to the east of Canalet Castle, after jumping off the left side of the bridge in the far east there. It also seems that in the raft area (, at one place, the stream goes upwards instead of downwards as in the above image, which means one becomes trapped at that point. Another place one can become trapped is to the right of the right-most switch in the room north-east of of the boss room in level 5.

Edit: It seems that I haven't mastered the wall jump/bounce quite yet. In the "cellar" room north-east of the boss room on the map, I always am at least one pixel (?) short, it seems, to reach the ladder.

Edit 2: And there I made it, but I would probably never be able to do it consistently. Perhaps this challenge should be moved to an optional area.

One question: I am not sure what the bow one can get at the start at level 5 is for. Nothing happens with my Start screen; there is no extra room, but the image of my initial bow is not changed.
Title: Re: Link's Awakening hack: New Awakening
Post by: katage on August 12, 2015, 08:30:45 pm
I'm sorry; I only just noticed the last message.

-I added a ladder to help the player escape should they jump left off the bridge near Kanalet Castle. I've checked the raft area and I use a different dropdown tile for the waterfall, which I had used to fix an old bug. I'll double-check to make sure everything works.

-I added a hole to prevent the player from getting trapped in the Catfish's Maw area.

-I increased the length of the ledge in the cellar room you mentioned, so it will be a little easier to reach.

-The level 5 Bow is optional. All it does is let you avoid having to buy the Bow normally. I figured it was a worthwhile prize for the shenanigans you have to do to get to the chest.

Let me know anything else you find odd.
Title: Re: Link's Awakening hack: New Awakening
Post by: Thanatos-Zero on October 14, 2015, 05:17:15 pm
I cannot solve Turtle Rock, Angler's Tunnel or even get all the treasures in the Eagle Tower...
I dunno, where the way is...
Also where is the Fire Wand?
Title: Re: Link's Awakening hack: New Awakening
Post by: Swifticuffs on February 19, 2016, 01:01:21 pm
Face shrine two rooms east of entrance. I cannot maneuver the bomb to blow the brick. I've been at it so long.... what am I doing wrong?